LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Waveform Chart and serious hair loss (Win/LV6.1)

Highlighted
I'm tearing my hair out trying to configure a Waveform Chart. Using the property node, I can successfully set the time axis to either 'Rel Time' or to Time & Date'; update mode to 'Scroll'; scale style to '0'; and Autoscale mode to off. But try as I might I can't get it to accept the following 3 properties:
Xscale, RngStart
Xscale, Increment
Xscale, MinorInc

The Chart vi has a mind of its own: it ignores my property settings and spaces the x-axis labels at whatever interval it likes. What's going on here?

Russ
0 Kudos
Message 1 of 4
(1,429 Views)
Highlighted
Probably you set one of properties to invalid value.
Make error indicator from your property node and see if there is error. If yes, click "explain error".
0 Kudos
Message 2 of 4
(1,429 Views)
Highlighted
Russ,

It's quite likely you are setting the scale increment values too small
for the axis grid label size. If you do this, LV won't be able to fit
all the labels on the axis and it will ignore your values and set up
the axis on its own. Try increasing the increment values or
decreasing the font size. Another thing you might try is changing the
format of the Time & Date. If you are showing the seconds and the
year, it will make your grid labels big and less likely to fit on the
axis using the increment you define. Try selecting "don't show year"
in the time format, and also select 24 hour (so that AM or PM won't
show) HH:MM time format to make is as small as possible. Finally, if
all this fails, try making your graph bigger to make more room on the
axis.

gm





Russ wrote in message news:<506500000008000000D7400000-1012609683000@exchange.ni.com>...
> I'm tearing my hair out trying to configure a Waveform Chart. Using
> the property node, I can successfully set the time axis to either 'Rel
> Time' or to Time & Date'; update mode to 'Scroll'; scale style to '0';
> and Autoscale mode to off. But try as I might I can't get it to
> accept the following 3 properties:
> Xscale, RngStart
> Xscale, Increment
> Xscale, MinorInc
>
> The Chart vi has a mind of its own: it ignores my property settings
> and spaces the x-axis labels at whatever interval it likes. What's
> going on here?
>
> Russ
0 Kudos
Message 3 of 4
(1,429 Views)
Highlighted
Try using the Scale.Offset and Scale.Multiplier property nodes. I have attached an example VI that
shows how to do this.

Chris_Mitchell
Product Development Engineer
Certified LabVIEW Architect

0 Kudos
Message 4 of 4
(1,429 Views)