LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

WSDL import broken in Labview 2010?

Highlighted

I have been trying to connect to a web service on the local network, using SOAP and WSDL. The first attempt was in Labview 8.2, which I have to run through a virtual machine since it doesn't work in Windows 7. I was able to connect to the server and import all the commands, but none of the responses contained any data. Trying the same thing with a standalone SOAP testing tool (Altova XMLSpy) worked fine, so I assumed the problem had to do with the virtual machine and decided to install Labview 2010.

 

Now in 2010, Labview refuses to connect to the server (with the identical URL that worked previously) giving the message "WSDL URL is not in the correct format. Please refer to the example".  It's not failing to connect, it's refusing to even try, so I guess it's some sort of problem with the validation.

 

My WSDL URL is of the form http://192.168.1.1:8888/SOAP?Service=DeviceManagement, while the example is http://localhost/DateService.asmx?SOAP. So, what part of that is the problem? I assume it doesn't require the URL to contain "WSDL", so has Labview 2010 lost the ability to cope with ports or something?

0 Kudos
Message 1 of 4
(1,055 Views)
Highlighted

Having played with it a little, it appears Labview demands that any WSDL file URL must end with "WSDL".  I can't find any such requirement in the w3c specifications, and as I mentioned it used to work in 8.2.  Bug, or has the web service importer been deliberately restricted for some reason?

0 Kudos
Message 2 of 4
(1,044 Views)
Highlighted

I don't think that there is a pattern of breakage relating to the WSDL URL - I have a WSDL URL that ends with xxxx?wsdl and I get the import errors as well.

 

We've developed clients using Java and Groovy without issue - only LabView seems to have a problem with the WSDL.

 

Seems a bit brittle, IMHO.

0 Kudos
Message 3 of 4
(1,002 Views)
Highlighted
0 Kudos
Message 4 of 4
(890 Views)