LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

WLS-9163 Error -201105: resource already reserved but create task works OK with USB carrier

Solved!
Go to solution

Hello.

I'm trying to configure a DAQmx task with a 9219 in a WLS9163.

The task has 4ch of "AI Temp TC".

 

If I run my program with the 9219 in a 9171 USB carrier everything works OK.

If I run the program with the 9219 in the WLS9163 carrier I get the following error when reserving channels in the task:

 

Error -201105 occurred at TemperatureMonitoring_v1.0.vi

Possible reason(s):

Resource requested by this task has already been reserved by a different task with conflicting settings.

Unreserve any other tasks using this device, or change their settings to be compatible with this task.

Task Name: _unnamedTask<A>

 

I'm not sure how the task config is different between the USB-9171 vs WLS-9163 carriers.

Here is the relevant block of code: 

TempMonitor_DAQloop.png

0 Kudos
Message 1 of 4
(1,886 Views)

Here are a few more details ...

 

I can create a 4ch AI Temp TC task in MAX with the WLS-9163, without any errors.

I'm also pretty sure this was working OK under LV 2010.  Not 100% sure but I wrote this program a couple of years ago I don't recall have any problems then.

 

Current firmware in the WLS-9163 = 2.0.1.f0

Current version of LabVIEW = 2012 SP1 f4

Current version of DAQmx = 9.6.2

0 Kudos
Message 2 of 4
(1,874 Views)
Solution
Accepted by topic author ebloohm

Greetings ebloohm

 

Is this behavior present if you skip the DAQmx Control Task.vi in your configuration? This problem has appeared in the past when a task has been explicitly reserved or committed and the task is reconfigured. So if possible, let’s try removing that VI from the configuration and tell us if that solves the issue. Have a nice day.

Luis J.
Applications Engineer
National Instruments
0 Kudos
Message 3 of 4
(1,840 Views)

That works.  

If I don't reserve the task it works just fine with both the WLS 9163 and the USB carrier.

 

Thanks!

0 Kudos
Message 4 of 4
(1,833 Views)