Showing results for 
Search instead for 
Did you mean: 

Voltage reach zero

Go to solution

Hi Every one


I'm new to labview. 


I use a high accuracy load cell and signal conditioner which provide precise excitation and output (10 V)


The problem that when I use the DAQ card (myDAQ) to measure the output voltage 


The voltage reaches zero for finite time as in the image however it is very stable at zero (at no load)

Also the same problem I found earlier when measuring a 9V DC battery


Any ideas?


0 Kudos
Message 1 of 9

Looks like a wiring problem to me.

Certified LabVIEW Architect
Certified TestStand Architect
0 Kudos
Message 2 of 9

All connections checked and good


aaaaaaaaaah very confused

0 Kudos
Message 3 of 9

Please post a diagram showing exactly how everything is connected.  Also pst yoru VI with some typical data saved as default.



0 Kudos
Message 4 of 9

Moment please


my signal conditioner is programmed via serial port


when I connect it to pc via usb-232 converter in the same time of aqcuiring data then all readings are ok and no ripples or spikes to zero 


The connection diagram and VI block are attatched





Download All
0 Kudos
Message 5 of 9
Accepted by topic author engcad

I suspect that you have a grounding problem. The signal conditioner is probably grounded through the USB/RS-232 connection when you have that connected. When it is not connected through the USB, it may not be grounded.


Try connecting the AGND of the MyDAQ to the 24 V DC- connection or to a ground connection on the signal conditioner.



0 Kudos
Message 6 of 9

thanks very much

0 Kudos
Message 7 of 9

grounding the signal conditioner had solved the problem

0 Kudos
Message 8 of 9

Thank you for letting us know.  When you report what solved the problem for you, it can help someone else with a similar problem.



0 Kudos
Message 9 of 9