LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Visual Studio 2010 .NET LabVIEW 2010

We have inherited some slightly older code that we are updating to the latest version of our development software. The lady who is working on the Visual Studio portion of the code is having problems with the code that interfaces to LabVIEW. I have attached a screen shot of her code with the error message. She is using Visual Studio 2010. I am working with LabVIEW 2010. Due to license issues, I have installed the LabVIEW run-time engine on her computer. (if that was done correctly)

 

We have searched the internet and tried a lot of the recommendations found but nothing seems to correct the problem. I am a LabVIEW developer and have not spent too much time looking into this as I have my part of the project to complete. We are hoping that one of the experts who monitor this board is able to tell us that this is a simple fix and can provide step by step instructions for her.

 

Thank you for any and all help that you can provide.

 

Bill

0 Kudos
Message 1 of 3
(1,743 Views)

Hi Bill,

 

Without seeing all of the code I can't be completely certain, but that type of error generally means that you have not included a necessary reference or library for the class, in this case _lvapp, or that the class is already being used elsewhere which is tying up that reference. So I would mention that to your partner and see if she can get it working correctly, my guess would be that the reference is missing but like I said without seeing all of the code I don't know for sure.

 

Hope that helps!

 

Peter W.

Message 2 of 3
(1,721 Views)

Thank you for your help. We have solved the issue. I am not sure exactly which problem cause it.

 

She downloaded and installed the evaluation version of LabVIEW 2010 until the company purchases some more licenses. She also fixed the code to point to the correct location of the .lvproj file.

 

It is working for the next 30 days.

 

Thank you.

0 Kudos
Message 3 of 3
(1,715 Views)