Showing results for 
Search instead for 
Did you mean: 

Visa serial VIs stopped working

Go to solution

I've been using LabVIEW (student edition 9.0) for my serial project and the other week i started having alot of trouble with the Visa serial VIs. None of them seem to be able to access the serial port, which I found strange since i had it working the week before on the same computer and nothing was changed.


I've read a few other responses - of which people have solved such as memory space or drivers being out of date ect. My issue is that it was working the week before and it just died on me. I have also tried it on another computer where it worked fine (also has student edition).


I downloaded all the newest Visa driver but i could not install them because the student edition could was not "compatible"
 with the drivers - wether or not it was the version 9.0 or student edition that gave me the error i'm unsure of.


What possible solutions do you think i could try? I was considering reinstalling it on my computer or installing it on my desktop and just let the 30 day trial run out.


I can include a copy of the program if needed, and the error code once i get a chance to run the program again.


Any help with this is greatly appreciated, I've found it rather irritating to have my work come to a halt because of an issue like this.

0 Kudos
Message 1 of 7
Accepted by Cowsgomoo2

Try to communicate to your serial device through MAX.  Also, is it possible that the COM port is tied up by something?  You should go to device manager to disable and enable the serial port to free up the resource.


Kudos and Accepted as Solution are welcome!
0 Kudos
Message 2 of 7

Ill give that a shot, thanks for the reply

0 Kudos
Message 3 of 7

Also, i forgot to mention - labview can't find any ports at all.


The error code is Error -107380702: Property Node (arg1) in VISA Configure Serial Port (Instr).vi

0 Kudos
Message 4 of 7

Hey Cowsgomoo2,


Are you able to perform a feedback test on your Serial Device? Instructions for doing this can be found here: 

If you are able to perform a feedback test the next step would be to confirm that your Serial Port is showin up in Measurement and Automation Explorer(MAX).  If it shows up in MAX are you able to communicate with it using Test Panels?  If it doesnt show up in MAX does it show up in the Device Manager.  Additionally the VISA drivers should be compatable with your student version of LabVIEW.  LabVIEW 2009 is compatable with VISA 4.5.1 to 5.0.3.  Please post back with your results and any additional questions.   

Kevin Fort
Principal Software Engineer
0 Kudos
Message 5 of 7
I apologize, my post did not update as it should have. Jyang solved my problem all I had to do wqs open max and labview started working again. I'm not sure what caused the problem in the first place but opening MAX "rediscovered " the ports for me in lv.

Thank you very much for your resposes, they helped a lot I never even thought of looking at MAX. Glad you guys did.

Thanks again for the help!
0 Kudos
Message 6 of 7

Glad that we can help.


Kudos and Accepted as Solution are welcome!
0 Kudos
Message 7 of 7