LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Machine with LabVIEW and cRIO - Inconsistent IP Settings

For a variety of reasons, my company does our LabVIEW development in VMs. However, the "Inconsistent IP Settings" status in MAX when connecting to cRIOs is such a nuisance. Usually, some combination of rebooting the cRIO, rebooting the VM, enabling and disabling the virtual and real network adapters will eventually result in clearing the "Inconsistent IP Settings" state. However, there's not a repeatable set of steps that we've found to do this.

 

BTW, I know that LabVIEW/MAX in VMs is not officially supported (https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019OB5SAM&l=en-US).

 

Does anyone have any recommendations for dealing with the issue? Specifically, we're using VMPlayer, but I've seen the issue in other VMs.

0 Kudos
Message 1 of 3
(788 Views)

What is your VMPlayer network configuration? If you're using NAT, try switching over to Bridge mode with a single physical adapter selected. Using this configuration I haven't seen any issues with cRIOs. I found using the NAT configuration just caused problems, both with MAX and other applications.




Certified LabVIEW Architect
Unless otherwise stated, all code snippets and examples provided
by me are "as is", and are free to use and modify without attribution.
0 Kudos
Message 2 of 3
(731 Views)

Thanks for the reply.

 

I usually have two adapters - one NAT for the host connection to the real internet, and one bridge for the cRIO. I usually turn off the NAT one whenever I have these issues. I typically have the bridge virtual adapters mapped to the physical adapter that's connected to the cRIO, with all the set to static IPs on the same subnet. Sometimes, disabling one adapter, setting the other to bridge and setting the subnet will fix the issue, but it's not a sure thing.


I'm running VMPlayer 7.1, so updating would probably be good, but it's not really an option right now.

0 Kudos
Message 3 of 3
(690 Views)