LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VRLM Pantalla negra

Hola.

Es la primera vez que hago uso de los foros de NI. Tengo una consulta acerca de los archivoa VRLM; resulta que exporto un modelo hecho 3DS Max y lo voy a visualizar en el 3D control picture, y lo unico que puedo observar es partes del dicho modelo o una pantalla negra. A que se podra deber este error? He leido que puede ser debido a las librerias OpenGL pero no entiendo como se relacionan. He intentado descargando modelos ya hechos pero obtengo el mismo resultado al cargarlos.

Estare muy agradecido con cualquier pista que puedan suministrarme.

PD: Uso LabVIEW 2011 y 3Ds Max 2010

0 Kudos
Message 1 of 4
(1,083 Views)

Hola Davitor39!!

 

 

Muchas gracias por utilizar los foros de National Instruments!!  Considerando la información de tu post, puede que el problema se encuentre directamente en la tarjeta de video o el controlador del mismo.  Para poder importar modelos 3D a LabVIEW, es necesario que la tarjeta de video de la computadora soporte OpenGL (Open Graphics Library).  De otra forma, obtendrás el comportamiento que has tenido hasta el momento, donde la aplicación no muestra errores pero el control se muestra con pantalla negra.  Para poder descartar esta posibilidad, quisiera pedirte que realizaras las mismas pruebas en una computadora distinta.  Si gustas, puedes compartirme tanto el modelo como la aplicación para que pueda tratar de reproducir tu problema por mi parte. 

 

Aprovecho también para dejarte algunos links que detallan la información que te describo:

 

Cannot View Objects in 3D Picture Control

 

LabVIEW Support for VRML Files

 

 

Espero que te sirva!!

 

Saludos!!

Anuar R.
National Instruments México y Latinoamérica
Ingeniería de Aplicaciones
www.ni.com/soporte
0 Kudos
Message 2 of 4
(1,034 Views)

Hola, gracias por responder!

Ya intente utilizando otro pc, modificando las propiedades de aceleracion de la tarjeta de vide, utilizando otro chipset de video (intel,ATI,NVIDIA), utilizando otro sistema operativo; y todos tuvieron el mismo resultado. Descargue un modelo para intentar, pero los resultados son evidentes en las siguientes imagenes (aunque no estoy seguro si  los modelos son exportados al formato correcto):

 

Visualizacion en Labview

Labview.PNG

 

 

 

 

 

 

 

 

 

 

 

 

 

Modelo original

Modelo original.PNG

0 Kudos
Message 3 of 4
(997 Views)
Highlighted

Hola Davitor39!!

 

 

¿Tuviste oportunidad de revisar los formatos soportados por LabVIEW en el link de mi post anterior?  Si gustas, puedes compartirme tanto tu código como el modelo que estas intentando importar, para poder reproducir tu problema.

 

Espero tu respuesta!

 

Saludos!

Anuar R.
National Instruments México y Latinoamérica
Ingeniería de Aplicaciones
www.ni.com/soporte
0 Kudos
Message 4 of 4
(885 Views)