LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VNA P9375A communication with labview

I currently am running windows 11 on my laptop. I have the 2022 Keysight connection expert downloaded and can communicate to my VNA via the connection expert. However, when I open my NI-MAX window, I cannot see the VNA as one of the possible options to connect to. I have downloaded all the drivers such as NI-VISA, NI-488.2, ect. I even noticed on some forums that I may have been required to tick the "enable keysight GPIB Cards for 488 programs" and I even ticked the box in the NI-MAX settings where I had to tick the box to enable tulip. After all this, I am still unable to make LabVIEW pickup/connect to my VNA P9375A device. Please let me know if there are any additional steps that I may have missed or may need to still do.

0 Kudos
Message 1 of 6
(1,054 Views)

Hi OSHAMOUT,

 

Were you able to figure out your problem because I ran into a similar problem initializing the VNA P9375A?

0 Kudos
Message 2 of 6
(612 Views)

Have you even connected your VNA through a GPIB card? Typically those devices are nowadays connected through Ethernet or USB. USB seems the only option for this device. The "enable Keysight GPIB cards" option (and the Tulip driver) only applies to when you use a physical HP/Agilent/Keysight GPIB interface card in your PC.

 

You need to have the Keysight IO Suite driver software installed: http://www.keysight.com/find/iosuite

Rolf Kalbermatter
My Blog
0 Kudos
Message 3 of 6
(593 Views)

Hi Rolf,

 

I'm connecting to the VNA through USB-C. Keysight connection expert confirms the connection but when attempting to initialize the device through Keysight NA labview drivers it throws a I/O error. Perhaps my resource string is incorrect.. PXI0::0-0.0::INSTR

 

I also have installed Keysight IO suite, IVI .net and C drivers along with labview drivers for the VNA. Would you have any suggestions or solutions?

 

Thank you,

TK 

0 Kudos
Message 4 of 6
(574 Views)

That resource string definitely looks wrong. Neither is it a PXI chassis nor does an address 0.0.0 mean anything.

Rolf Kalbermatter
My Blog
0 Kudos
Message 5 of 6
(569 Views)

Hey Rolf,

 

I've solved it. Apparently the previous visa address was for the instrument itself but the one I needed was a hiSLIP so I needed to add TCPIP0:: and my connection::hislip_PXI10_CHASSIS1_SLOT1_INDEX0::INSTR. for remote interface. It runs now 🙂

 

Thanks,

TK

0 Kudos
Message 6 of 6
(557 Views)