LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VISA set-up

Solved!
Go to solution

I don't see my instrument in the VISA resource name selection box in the Labview example "Agilent 34970 EZ Scan.vi" , my instrument is an Agilent 34970A.  The only possible choices are "COM3" or "Refresh".

I have the same problem with other instrument.  There seems to be something missing for the instrument to be detected correctly ??  Any help would be greatly appreciated.

 

PS. My 34970A is connected through a 82357B GPIB to USB adapter and I've configured the instrument driver with the "Keysight Connection Expert".

 

Thanks

 

Jean-Guy

0 Kudos
Message 1 of 4
(291 Views)

You need to configure your GPIB adapter to show up in MAX.

 

Have a look at this old thread:

 

https://forums.ni.com/t5/Instrument-Control-GPIB-Serial/Agilent-usb-GPIB-82357B-is-not-shown-in-NI-M...

 

There's a number of solutions there, I expect one will probably make it appear in MAX and then your device will be detected under it.

0 Kudos
Message 2 of 4
(268 Views)
Solution
Accepted by JeanGuy

You need to enable the Tulip Passport in NI-MAX

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 3 of 4
(258 Views)

Thanks RTSLVU, this has corrected the problem I had with the instrument not detected.

 

Jean-Guy

0 Kudos
Message 4 of 4
(177 Views)