Showing results for 
Search instead for 
Did you mean: 

VISA "Find" returns wrong port numbers

Starting a new thread on a topic I've been wrestling with for some time...


I have a test that utilizes two different USB cables functioning as virtual com ports.  The first part of my LV program uses the "VISA Find" tool to report back all COM ports in use.  The other day I plugged in the two USB cables and I saw Windows Device Manager assigned them to COM4 and COM9.  But when I ran my program, VISA Find returned values of COM4 and COM12.  I looked in Device Manager and it showed nothing using COM12.  I double checked my com port aliases in MAX and everything looked good.


I closed that VI and tried a different VI that also starts with the "VISA Find" and that one returned values of COM4 and COM9.  So I closed that VI and returned to the original one, and again it reported COM4 and COM12.  No COM9.


Any idea why the VISA Find in that one VI is returning a non-existant COM port value?  I'm using LV 2010 and running it under Windows 7.


(Note: I didn't attach any code because the very first step in each VI is the "VISA find" tool, both set up identically, so the rest of my code is irrelevant to the problem)

Amateur programmer for over 10 years!
0 Kudos
Message 1 of 2

This seems unusual to me.  Could you try to plug in a 3rd device and try that out?  Once you test it, try to reassign it a different com port and see if that VI in question responds to it.  If you don't have a third device, could you try to reassign the com ports of one of your current devices?



Bobby Breyer
Applications Engineer
National Instruments
0 Kudos
Message 2 of 2