LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VISA invalid reference to a given object

Hey guys - frustration is starting to set in and I can't figure out why my devices continue to disconnect or I keep getting a invalid reference to a given object error.

 

What this program is supposed to do is to connect to a given COM port and extract data from a hardware device and then place the data into an Excel file. I keep getting a invalid reference on the Mitutoyo MIG4 device. No matter what I do, I can't seem to get rid of this error.

 

My guess is this is something simple but if someone could take a look at it and see what is up, I would be grateful. Program being used is LabVIEW 2018.

0 Kudos
Message 1 of 3
(831 Views)

I notice that you use a blank Control wired to your VISA Configure Serial Port.  Try replacing the Control on the Block Diagram with a Constant (the easiest way to do this is to right-click the Control and choose "Change to Constant" from the Drop-down menu), clicking the little triangle on the Constant, and choosing the VISA Port you are using (e.g. "COM1").  [Note that if you have multiple VISA ports and need to choose one at run-time, you may need to do something a bit more sophisticated].

 

Bob Schor

0 Kudos
Message 2 of 3
(793 Views)

Bob - you are correct. That is a Sub VI and it should get the COM Port information from the VISA wire getting wired into that from the KeyboardWedge.vi (the top level VI).

0 Kudos
Message 3 of 3
(781 Views)