LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VISA Read Error using lcr meter 4284a

Highlighted

Hi,

 

I'm setting up a VI to do some longterm measurements regarding capacitance. Unfortunately I allways get an error when trying to use the read VISA: -1073807339: VISA:  (Hex 0xBFFF0015) Timeout expired before operation completed.

I'm on this problem now for one and a half days and allready tried some stuff, for example http://digital.ni.com/public.nsf/allkb/E6DFA2B8D7E99F9886256C14005E82F7 . I tried reading out just one byte and checked the device settings (though the only thing I actually could check was the GPIB address). I also tried changing the VISA session timeout, allthough I'm not sure, wether I did that correctly (I'm quite new to LabView) and put some delay between the write and read visa. I allways get the same errors when I use the latest driver VIs. When using MAX, I get the same errors (BFFF0015: Timeout expired before operation completed).

Since there don't seem to be any software issues here, there must be anything wrong with my hardware setup, which consists of:

HP Precision LCR Meter 4284a (of course), which is connected to a GPIB-232CV-A converter, which is connected to a Keyspan USA-49WLC Serial to USB adapter. I checked all the cables (apart from the GPIB cable, because at the moment I don't have any other) and made sure the GPIB addresses of the converter and the device were the same (I also used different ones). To make sure I don't use the wrong settings, i'm going to list them

for the converter:
GPIB-232CV-A:
C Mode
Switches 6 and 7 Off: Timeout Termination

right side:
9600 Baud
odd parity
parity generation/checking disabled
1 stop bit per character
7 bits per character
Xon/Xoff protocol enabled


GPIB Addresses are the same (17).

 

The keyspan adapter works fine with other devices (like a keithley 6517a, which is running at the moment at GPIB address 24).

The exact errormessage is: Error -1073807339 occurred at VISA Read in Agilent 428X Series.lvlib:Fetch.vi->capacitance.vi

 

I'm also using a quite new version of the NI-VISA (4.2) and installed the latest drivers for the keyspan adapter. The operating system of the PC is Windows XP Professional SP2.

 

I hope you can help me, I'm really kind of annoyed by looking for a solution the whole day :/.

0 Kudos
Message 1 of 2
(965 Views)

I just found out that the VI for the currentmeasurement with the keithley 6517a has the same error but still works fine. Now I also tried to adjust the serial data bit and parity settings via the VISA configure serial port function but still no improvements.

0 Kudos
Message 2 of 2
(954 Views)