Showing results for 
Search instead for 
Did you mean: 

VI using ActiveX works in XP, loads in Win7 64 bit but crashes in Win7 32 bit.

Go to solution

I have a VI that works in windows XP, loads in Windows 7 64 bit (for editing only) but crashes Labview in windows 7 32 bit.  I know the code works, but I haven't tried it on this particular PC before so I'm assuming there's a configuration error somewhere, but dang if I can find it.


I've included a screen shot of the error and a copy of the VI in question.


Ro ma wa ichi ni chi ni shi te na ra zu
Download All
0 Kudos
Message 1 of 11

Anyone?  Anyone?  Bueller?


I've already tried running labview as an Administrator.


Ro ma wa ichi ni chi ni shi te na ra zu
0 Kudos
Message 2 of 11

What are you ActiveX'ing to ?


Do you have the same version of that application on both PCs?

0 Kudos
Message 3 of 11

It would seem you use a particular .Net component and that might have trouble under Windows 7 for some reasons. It could be either a problem in the .Net component itself or possibly the fact that it was not written for the .Net version that is on your PC. You definitely will have to take this up with the manufacturer of that .Net document as they are the only ones who can tell you more about the compatibility of their software with particular Windows and .Net versions.


The next step of action would be to use a C# written test application to load the component on that machine and execute the same operations.

Rolf Kalbermatter
Averna BV
0 Kudos
Message 4 of 11

I'm active-Xing to a file from Texas Instruments (bq80xRW.ocx).  I double checked that my installs matched, and the version on the PC that failed is newer, so I replaced it with the version from the PC that works.  Still no good.


I also confirmed that I have the same version of .Net, .Net extended, and .Net client on both machines.


Any other suggestions of where to look would be appreciated.  I'll follow up with Texas Instruments while I'm at it.




Ro ma wa ichi ni chi ni shi te na ra zu
0 Kudos
Message 5 of 11

The funny thing is that the software provided by Texas Instruments (BQEasy) works fine on this machine.  So the way I'm calling the OCX is different in my code than it is in how TI does it, and different from how I'm doing it in every other machine I've run this on that works.


I've checked my registries for the BQ80xRW, and they're identical across both computers.




One thing I noticed is that the old TI drivers I had on file didn't install on this system, but the new drivers from TI's website did. That might be the problem right there.


Ro ma wa ichi ni chi ni shi te na ra zu
0 Kudos
Message 6 of 11
Accepted by topic author gdecker



Problem solved.  It turns out that TI requires a spectial Developer version of their drivers to work with labview, otherwise labview won't get permission to use the control and crash.


Installed the Dev kit and now everything is normal.


The dumb thing is that I actually knew that, but it's been so long since I had to configure a new PC to work with labview that I forgot about it.


Ro ma wa ichi ni chi ni shi te na ra zu
0 Kudos
Message 7 of 11

Could you please share the link?

I have the same problem!

0 Kudos
Message 8 of 11


Can you share the link where we can download the dev kit.

I have the same issue.



0 Kudos
Message 9 of 11



We have to program a Ti components using the ActiveX :'Bq80xRw' through Labview software.

We use a KitEV2300 to communicate to the Bq40Zxx.

Could you tell us what are the commands to program a '*.SREC' file ? And if it's possible to send us VI programs in relative of the activeX :'Bq80xRW'.

Thanks in advance


Batteries Test Manager

0 Kudos
Message 10 of 11