LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VI needed for communicating with Agilent 8712 ES

Hello Tech support,

 

I am using network analyzer "Agilent 8712 ES", and MAX cannot recognize the device it says "the instrument did not respond to *IDN? query?"

 

I have gone through other forums and learned that since this machine is old it doesnt recognize some of the newer commands and its alright, I can still communicate with the device. Thats good but the problem is I cant find a VI for this instrument.

 

Can you please help me locate the VI. OR if you already have it can you please forward it to me. It will be of great help.

Thanks & Regards,

Ajay

Student

0 Kudos
Message 1 of 9
(1,378 Views)

Hi Ajay, 

 

We have a ton of drivers at ni.com/idnet 

 

A quick search for your instrument brings up a driver, but it is in CVI. You can import a CVI driver into labview (see here), you may need to install a trial version of CVI. We stopped supporting the Instrument CVI Instrument Driver that the tutorial refers to in later version of labview, I think it was 2009. If you are using a later version of labview you can either just install an earlier version to import dllls with the CVI wizard or use the Import Shared Library Wizard (here), which performs the same function but gives you different looking subVIs.

 

I would go ahead and make sure your device is responding to commands first though. 

 

 

Jesse Dennis
Engineer
INTP
0 Kudos
Message 2 of 9
(1,374 Views)

Hi Jesse,

 

Thanks for the reply I looked through the drivers and it seems NI website directs me to a third party which apparently doesnt have the driver I need. Probably they moved it considering the system is "Obsolete".

 

I will try to contact Agilent guys, hope they will still be having the driver with them.

 

 

Thanks a ton !

 

Regards,

Ajay


@Jesse_D wrote:

Hi Ajay, 

 

We have a ton of drivers at ni.com/idnet 

 

A quick search for your instrument brings up a driver, but it is in CVI. You can import a CVI driver into labview (see here), you may need to install a trial version of CVI. We stopped supporting the Instrument CVI Instrument Driver that the tutorial refers to in later version of labview, I think it was 2009. If you are using a later version of labview you can either just install an earlier version to import dllls with the CVI wizard or use the Import Shared Library Wizard (here), which performs the same function but gives you different looking subVIs.

 

I would go ahead and make sure your device is responding to commands first though. 

 

 



@Jesse_D wrote:

Hi Ajay, 

 

We have a ton of drivers at ni.com/idnet 

 

A quick search for your instrument brings up a driver, but it is in CVI. You can import a CVI driver into labview (see here), you may need to install a trial version of CVI. We stopped supporting the Instrument CVI Instrument Driver that the tutorial refers to in later version of labview, I think it was 2009. If you are using a later version of labview you can either just install an earlier version to import dllls with the CVI wizard or use the Import Shared Library Wizard (here), which performs the same function but gives you different looking subVIs.

 

I would go ahead and make sure your device is responding to commands first though. 

 

 




0 Kudos
Message 3 of 9
(1,348 Views)

Hai,

Please download the Agilent driver from thw following link. After downloading convert that labwindows driver to labview driver.it might be useful.

 

http://sine.ni.com/apps/utf8/niid_web_display.model_page?p_model_id=5891

0 Kudos
Message 4 of 9
(1,335 Views)

Where did you look at Agilent? I found this.

0 Kudos
Message 5 of 9
(1,324 Views)

I usually don't go hunting for drivers.  Instead, I go hunting for the programmer's guide.  😄

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 6 of 9
(1,292 Views)

Hello guys,

 

After some research I have reached to the conclusion that we dont have a direct VI available for this device Agilent 8712ES, So we will have to make our own VI's for the instrument.

 

 

Thanks for the help !

 

Regards,

Ajay

0 Kudos
Message 7 of 9
(1,276 Views)

It's easier than you think.  Good luck! 🙂

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 8 of 9
(1,259 Views)

Hello, Did you ever write a VI for communicating with the 8712ES network analyzer?  I was wondering if we might be able to borrow from your work.  We are Students at UCDenver.edu and the software will be used for educational purposes.  Thank you -Ryan Smith

0 Kudos
Message 9 of 9
(1,231 Views)