LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VI has an error of type 2208, 42308,302208

Since i'm using Labview 2010 and 2010SP1 i get the following error when i start an executable created in Labview:

 

VI has an error of type 2208. The full development of Labview is required to fix the errors. Same message with error 42308 and 302208.

 

History:

 

the initial project is created in labview 2009, that never gave this problem

When i created an exe in Labview 2010SP1 of the same project, i got no errors during the build.

When the exe is copied to another machine that holds the latest verion of the LV 2010 runtime, the error messages appear.

I mass compiled the complete project and no errors, files not foud or what so ever in the log -> clean log.

 

I checked the forum on this issue and i saw a post for the same error but this was caused by shared variables. I do not use shared variables in my project, so no help.

 

Has someone an idea what can cause this behaviour?

 

thanks

 

 

Frank Van Vaerenbergh

Project Engineer

Rohde & Schwarz Belgium NV.

 

0 Kudos
Message 1 of 8
(4,317 Views)

Hallo,

 

i have the same error message (VI has an error of type 2208) and the same LV version.

But so far, the only think I know is, that this error occurs only when I try to run builded EXE application in a different folder than it was compiled into.

 

Do someone know how to fix this behavior?

 

Thanks.

 

Petr Preucil

T-Systems Czech Republic

Petr Preucil
T-Systems Czech Republic
0 Kudos
Message 2 of 8
(4,300 Views)

Hello,

 

I have received the same error message but just for 2208, but the message repeats itself three times in the error box. The stand-alone application runs fine on the build computer but the error message occurs on the target computer. Has anyone else had this problem and been able to fix it?

 

Thanks

0 Kudos
Message 3 of 8
(4,268 Views)

I have a VI with error 2208.The VI uses the NI report class.

I need to explain the architecture of the application. I have an executable that is built using LV2011. The application calls VIs dynamically. The VIs are located in a LLB. The LLB is built as a source distribution. When the LLB is built, folders are added that contain the VIs referenced by the error VI. The referenced VIs are also put in the LLB . The VI with the problem uses the report library. The final bit of information is that the VI opens fine on my development machine(XP). When I try the application and corresponding LLB on a test machine (W7), I get the error.

 

I have tried to resolve the error in a few ways. First, I thought that having folders with the Report VIs and in the LLB was the problem. So I excluded the report VIs from the LLB. The result was that I discovered the missing VIs. I thought that there was a compile error. I added the VIs to the LLB but the error VI failed to find the VIs. The error was missing VIs at this point. I tried to add the whole directory to the LLB but the 2208 error returned. I looked at the LLB but the missing VIs were not included even though I included the whole directory. If I examine the folder in the project, the missing VIs are listed. 

 

 Jim West Summitek Instruments

0 Kudos
Message 4 of 8
(4,178 Views)

Because LabVIEW don't tell much about the problematic VI. No idea where the problem come from.

 

I used the Diagram Disable Structure in a "divide and conquer" manner to find the defect VI. Once I located that VI, I made an aesthetic modification (move a control on the front panel), save the VI and build again. It solved the problem for me.

 

I Guess doing a mass compile would have done the job.

0 Kudos
Message 5 of 8
(3,813 Views)

I tried mass compilation ... and it worked for my projects,

 

 

0 Kudos
Message 6 of 8
(3,780 Views)

This can still happen in any version of LabVIEW.

It is a dll version issue.

You probably just copied the exe file without copying the Data directory which includes the updated .dll files needed.

 

BR,

Amir.

0 Kudos
Message 7 of 8
(2,014 Views)

I received error 302208 on the target PC after modifying my Actor Framework-based LV2014 SP1 application. Previous versions ran fine. But after adding a read shared variable functionality, the app throws on start a lot of errors like "resource not found, an error accoured loading VI IMAQ Write Image And Vision Info File 2. Load Error Code 3: Could not load front panel "....

 

I was able to start the program on several laboratory PCs without any problems. Only the intended computer fails.

 

The solution was to install the development environment on the target PC and recompile the project.

0 Kudos
Message 8 of 8
(972 Views)