LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

VI crashes labVIEW on opening

Solved!
Go to solution

Last week I got the same problem. LabVIEW stops working and closes. I'm not trying to open any VI's, just the program itself. I have reinstalled the whole thing:

- I uninstalled everything.

- Then I installed LV 2010 and the f2 patch.

- After that I installed LV2010 SP1.

 

And still the same error.

 

The error occurs on "Finalizing initialization". This is now really annoying because it takes many hours to reinstall LabVIEW. 

 

Edit: And NOW it suddenly works. I've tried opening it three times and then it worked. Well as we say in Norway: "Alle gode ting er tre!". It means that the third attempt will always work. Sometimes...

Regards,
Even
_________________________________
Certified LabVIEW Associate Developer

Automated Test Developer
Topro AS
Norway
0 Kudos
Message 31 of 37
(436 Views)

Yes, it would appear that it is the culprit.

Now the challenge is to find that insane object!

 

You may hae some hint by looking at the error report, if one was created.

 

Look in : "My Documents\LabVIEW Data\LVInternalReports\LabVIEW\"

You should find a folder with the version of LabVIEW that you are using.

There should be a long folder name consisting of alpha-numeric characters.  Check the date of the folder and see if it matches the time & date of the crash.

 

Inside that folder should be a lvlog.txt.  And some dmp files.  Check out the lvlog.txt file to see if it points to anything that could identify which VI to look for.

______________________________________________________________________
0 Kudos
Message 32 of 37
(424 Views)

i am not getting a report created....

 

in LV 8.5.1 i also get this error message, someone can tell me what this could mean?

 

fpsane.JPG

0 Kudos
Message 33 of 37
(405 Views)

so for all those who might have the same problem.

 

i was able to resolve the conflict by copying all of the block diagrams content into a new vi.

And then using the new vi.

 

 

0 Kudos
Message 34 of 37
(395 Views)

That's strange that you r are seeing it with LV8.5.

As a matter of fact, your solution is how we did it back in the days of LV7.1.

 

By copying the code to another VI, the rogue object did not get copied.

______________________________________________________________________
Message 35 of 37
(380 Views)

I just encountered a problem opening an fpga vi in labVIEW 10.0.1 SP1.

In this case LabView crashed without error or warning while loading the project.  I was able to open the vi from the welcome window and diagram-disable the section I had been working with, and that allowed the project to load without crashing.

Eventually I found a feedback loop with the input unwired (not the init terminal) causing the problem.

 

I Hope this helps someone else!

 

0 Kudos
Message 36 of 37
(354 Views)

Hey guys, hope someone can help me.. I don't have access to a higher version from LabVIEW 2010 SP1, but I'm encountering similar issues as previous posters.  Here's my VI that keeps crashing when I open it.  I also tried to download the latest LabVIEW 2010 SP1f4 but it didn't help.

 

Hey, before I finished my original post I tried to open it in LabVIEW 2010 for Mac (I'm doing my work in LabVIEW 2010 SP1 for Windows).  I was able to recover my work!  So hopefully others who are encountering the same problem can have another thing to try.  Good luck!

0 Kudos
Message 37 of 37
(255 Views)