LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VI convertion from old to newer version

I have a couple of  VI's that control some functions of a spectrometer.These VI's were written in an older version of Labview

and now that I have updated to 8.5 I get the error "VI version 4.0.2 is too old to convert to current LAbview version 8.5"

Is there anyway to convert them?

Thank you

0 Kudos
Message 1 of 16
(2,629 Views)
You would have to open them first in a slightly older version of LV such as 8.0, 8.2, save them, then open them in LV 8.5.  If it's only a few, you could post them to the forum and ask somebody to assist you in upgrading them.

Message Edited by Ravens Fan on 01-10-2008 11:25 PM
Message 2 of 16
(2,624 Views)
Even if I had saved them in v7.0,which I didnt cause it was never installed on my pc,they should work if I unistall them but they dont. I only have v7.0 and v8.5 so I cant convert them .And the thing is that at first they worked perfectly with 8.5.Isnt there any other way to convert them?Please dont tell me I bought 8.5 for nothing.
0 Kudos
Message 3 of 16
(2,569 Views)
Since you say you have 7.0, open the drivers in that version and save them. The earlist version that 8.5 will opne is 6.0, I believe. If you had them opne before, it must have been with a different version of LabVIEW or it was a driver that someone had already converted.
Message 4 of 16
(2,560 Views)
Raven,

I have a 3.5 Mb file (PCV.EXE) that was made with LabView 4.0. I can't open it with LabView 8.5 which is the version that I have.  Could you assist in converting that file to 8.5 so I can see the three VI that are inside.

Thank You,
Elier
0 Kudos
Message 5 of 16
(2,329 Views)
Hi Elier,
where is your file?
Mike
0 Kudos
Message 6 of 16
(2,327 Views)
Is there a way I can send it privately?

Thank you,
Elier
0 Kudos
Message 7 of 16
(2,324 Views)
If you have an exe, you can't open the VIs in any version of LabVIEW. An exe has no block diagram. You need the original VIs.
0 Kudos
Message 8 of 16
(2,316 Views)
Hi,

This chart displays what versions can be opened and saved in what other versions. Since your VIs are in 4.0., all you need to do is to save these VIs in an intermediate version which is 6.0.0 or greater. Once this has been done, the VIs can be opened in 8.5. We recommend that you save your VIs to an intermediate version and mass compile them and then open them up in 8.5.

We have tried to make this as painless as possible, but over the years there have been some issues that have come up, so make sure to test out the application during the upgradation process.


Warm regards,
Karunya R
National Instruments
Applications Engineer
0 Kudos
Message 9 of 16
(2,274 Views)

Hello - i have a VI which is in version 5.0.1 can some one convert it to newer version like labview 10 or atleast 8.6. Thanks in advance 🙂

0 Kudos
Message 10 of 16
(1,617 Views)