LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VI_ERROR_RSRC_BUSY : COM1is unknown in VISA interactive control

Highlighted

Hi Everyone, 

 

It's been 3 weeks that I'm struggling with this issue that my motor controller is not getting connected to PC by COM1 :

I have a spectrograph connected by USB port converter but it used to be there and we never keep two software (LabView and Winspec (for spectrograph: connected by COM4)) open at the same time. 

 

I tried changing PC cause I though RS-232 might be dead cause we had power fluctuation issue, checked the electronics and every possible option. 

 

When I try to run the motor by LabVIEW it's giving me this error:  

 

 

I appreciate any feedback. 60AA1CA5-D532-4B69-8A76-804109B38C4F_1_105_c.jpeg

IMG_3028.jpgIMG_3029.jpg

0 Kudos
Message 1 of 7
(146 Views)
Highlighted

Did you try reinstalling the drivers for the USB/RS-232 converter?

 

Did you try a different USB/RS-232 converter?

0 Kudos
Message 2 of 7
(139 Views)
Highlighted

The motor controller is directly is connected with RS-232.

 

To use USB driver instead of RS-232 we tried the following: 

We tried using a USB convertor and changed the COM port in LabVIEW as well and got the same error. 

But the issue is the motor controller is old and think It's not communicating with USB. 

0 Kudos
Message 3 of 7
(133 Views)

Well the motor controller isn't communicating with USB.  It is communicating with RS-232.

 

If you changed from a hard RS-232 com port in the PC to a USB-RS-232 converter, then the controller is still trying to use RS-232, it is the converter that is adapting it to the USB interface.

 

With the error message you show in device manager, that indicates a problem with the driver for the converter or the convertor itself.

 

If you had a failure to communicate with a hard RS-232 port before, perhaps it also had a driver problem (which would give the same appearance in Device Manager.)  If the RS-232 port looked okay in device manager, but the device still failed to communicate, then perhaps it is a different problem that the RS-232 port inside the instrument is broken, which seems possible considering you said you had a power incident and the instrument is old.

 

There isn't much help we can give beyond this on the forum.  You might need to talk to whoever knows the most about PC's and that instrument in your organization to get help.

0 Kudos
Message 4 of 7
(115 Views)
Highlighted

''Well the motor controller isn't communicating with USB.  It is communicating with RS-232.

 

Yes, the spectrograph is communicating with USB converter. 

We use RS-232 directly for the motor controller. 

 

''perhaps it is a different problem that the RS-232 port inside the instrument is broken''

We thought about this and changed the PC. 

0 Kudos
Message 5 of 7
(96 Views)
Highlighted

So are you saying you have two different things connect?

 

A motor controller with RS-232 and a spectrograph with USB?   I guess I didn't understand your setup clearly.  I thought you were only talking about one thing.

 

When you say, "spectrograph is communicating with USB converter",  does that mean (specifically) a USB to RS-232 converter?

 

 

When I meant that possibly the RS-232 inside the instrument is broken (I guess I should have said motor controller), changing the PC isn't going to help if the problem is with the port in the motor controller.

 

We aren't going to be able to help much except throw out some ideas to you.  When it comes to troubleshooting real equipment, you need to be able to put your hands on the equipment, which we can't do.

 

 

0 Kudos
Message 6 of 7
(74 Views)
Highlighted

''A motor controller with RS-232 and a spectrograph with USB?''

Exactly

 

''When you say, "spectrograph is communicating with USB converter",  does that mean (specifically) a USB to RS-232 converter?''

Yes, it is. 

 

The thing is when I use the joystick to run the motor controller it works. 

 

Based on what I read from people here with the same problem they were referring to some issues with NI visa! I thought I might have the same problem, but not sure how to confirm everything is working properly with VISA and it's an instrumental problem, not a software issue. 

0 Kudos
Message 7 of 7
(70 Views)