LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Using Basler ace GigE Cameras

Hi All,

 

I just got in two Basler ace acA640-100gc GigE cameras.  I can run them using Basler's software, "pylon Viewer," but when I try to run them in NI MAX or LabVIEW, I get an error with this message:

 

"The system did not receive a test packet from the camera. The packet size may be too large for the network configuration or a firewall may be enabled."

 

I set up my network adapter to accept jumbo packets.  Since I can run the cameras using pylon Viewer, I assume that there are no FireWall issues.

 

Do I need to set parameters in NI MAX and/or LabVIEW before I can run these cameras on NI software?

 

Thanks,

 

FB

Forbes Black
Lapsed CLAD, LV 2017
0 Kudos
Message 1 of 21
(3,811 Views)

What does the packet size in Acquisition Attributes in MAX say?

Adnan Zafar
Certified LabVIEW Architect
Coleman Technologies
0 Kudos
Message 2 of 21
(3,803 Views)

8000 bytes.  I have my network adapter configured twith a Jubo Packet value of 9014 Bytes.

 

Thanks!

Forbes Black
Lapsed CLAD, LV 2017
0 Kudos
Message 3 of 21
(3,801 Views)

What happens when you decrease that packet size to 1500? I would also recommend turning the firewall off for a few minutes to see if it works.

Adnan Zafar
Certified LabVIEW Architect
Coleman Technologies
Message 4 of 21
(3,799 Views)

Aha!  Despite my network adapter setting, it appears that I can use the cameras in NI MAX at Packet Size settings up to 1500 bytes.  If I go higher than that, I get the error message.

 

This might work for me, but if I could convince the system to transfer bigger packets, would I get better performance from the cameras?

 

Thanks again,

 

FB

Forbes Black
Lapsed CLAD, LV 2017
0 Kudos
Message 5 of 21
(3,798 Views)

Sadly, I cannot turn off the firewall.

 

I'm negotiating that with IT now.

 

 

Forbes Black
Lapsed CLAD, LV 2017
0 Kudos
Message 6 of 21
(3,796 Views)

Hmm I suspect the card is not working well with the driver but cannot be sure. Be sure to make your timeout higher, maybe around 5000ms (the other attribute on the same tab).

Adnan Zafar
Certified LabVIEW Architect
Coleman Technologies
0 Kudos
Message 7 of 21
(3,792 Views)

Yup, I have it set at 5000.

 

I am wired through a network switch.  Do I need to configure that, too?

 

Now I can make it work in NI MAX, but it still gives me the same error in LabVIEW, using the Vision Acquisition Express VI.  I cannot find a packet size setting in the VI properties.  Do you know if it is in there somewhere?

 

Thanks again.

Forbes Black
Lapsed CLAD, LV 2017
0 Kudos
Message 8 of 21
(3,789 Views)

I have heard people having problems with network switches. Try to connect it directly if you can and see if that fixes the issue.

 

As long as you SAVE (top left) the configuration changes, it should work with the same setting in LabVIEW.

Adnan Zafar
Certified LabVIEW Architect
Coleman Technologies
0 Kudos
Message 9 of 21
(3,787 Views)

OK, I've got them working in LV.  I'll leave this open for a bit, in case someone has good ideas about the packet size limitations.

 

Thanks again for all your help!

Forbes Black
Lapsed CLAD, LV 2017
0 Kudos
Message 10 of 21
(3,785 Views)