LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Updating NiDAQmx for vilogger effect labview 6.0?

Good morning,
 
I'm currently running LabView 6.0, but want to evaluate VI-Logger for a separate application. To install this, I have to uninstall the current version of NI-DAQ mx (6.8.x) and upgrade it to version 8.1.
 
Will this upgrade effect my ability to use LabView 6.0? There are no plans to upgrade that to the latest version.
 
Thanks.
0 Kudos
Message 1 of 2
(2,204 Views)
Hi krasing,

The quick answer is yes, this would affect your ability to use LabVIEW 6.0.  You would not have Traditional DAQ functionality in LabVIEW 6.0 after installing DAQmx 8.1.

NI-DAQ 6.8.x is a Traditional NI DAQ driver (The earliest version of DAQmx was 7.0).  DAQmx 8.1 will not work with that version of NI-DAQ so you are right that you would need to uninstall the 6.8.x version.  Since DAQmx does not have support for LabVIEW 6.0, you would lose your DAQ functionality all together for LabVIEW 6.0 if you were to install DAQmx 8.1. 

There are versions of NI-DAQ that have Traditional and DAQmx included, and that have Traditional support for LabVIEW 6.0.  You can find a quick reference list at the following page:

http://digital.ni.com/public.nsf/websearch/97D574BB1D1EEC918625708100596848?OpenDocument

Note:  The Traditional Driver is supported in LabVIEW 6.0.  DAQmx is not supported at all in LabVIEW 6.0, but you could find a version that will allow you to have both on your computer at the same time, and still have Traditional support for 6.0.

Hope this helps!

Adam W
National Instruments
0 Kudos
Message 2 of 2
(2,190 Views)