LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Upconvert VI Requests

Please use the Version Conversion board to post any requests to upconvert or downconvert your VIs.
In your post, please indicate:
Source LabVIEW version
Target LabVIEW Version

 

**Once converted, please mark the thread as Solved by selecting "Accept as Solution".

 

Please remember this is not a space for code discussion. This is just a space for you to post the VIs you need to be converted to an older or newer version of LabVIEW. If an issue arises where you need further assistance after the conversion has been completed (for instance, if you need the converted

VI to be removed from the forums) please select "Report to a Moderator."

Message 1 of 1,261
(26,691 Views)

smercurio_fc wrote:

A Downconvert VI Requests thread was created to try to keep all conversion requests from a newer version of LabVIEW to an older version of LabVIEW in one place.

 

 

 

While there is sort of a thread to post requests to upconvert VIs from LV 5.0 to 8.5, I figured a more general "upconvert" thread would provide symmetry to the Downconvert VI Requests thread.

 

 

Please use this thread to post requests to upconvert VIs from an older version of LabVIEW to a newer version of LabVIEW.

 

In your post please indicate:

 

source LabVIEW version

target LabVIEW version 


 

Thanks for creating this thread, SMercurio!

 

Here is my request: some (not all) VIs in the attachment  are LV3.1, but my oldest installed LV is 7.1.

 

I'd be grateful if someone could convert them to LV 8.5 (or at least LV7.1)

 

-Franz

0 Kudos
Message 2 of 1,261
(26,503 Views)
What's wrong with the 8.0 driver?
0 Kudos
Message 3 of 1,261
(26,483 Views)

Dennis Knutson wrote:
What's wrong with the 8.0 driver?

 

There's probably nothing wrong with that driver, but the LLB that I'd like to upconvert is a collection of my own VIs I wrote years ago, and already then (and still now) I preferred to write my own 'lean' drivers (lean= no VISA, plain IEEE488.2 code). Also some of the VIs in the posted LLB don't have a counterpart in the official driver suite...

So, if anyone could upconvert it, it would be great.

 

But  I'll have a look at the more recent  HP3458 drivers to see what they can do for me.

 

-Franz

0 Kudos
Message 4 of 1,261
(26,469 Views)

Using VISA does not add enough overhead to really notice, imho, but to each their own I guess.Smiley Wink

 

Since converting from 3.1 requires the conversion kit (which is LabVIEW 4.0), you might have to wait awhile since I doubt very many users still have 4.0 installed. If you were to request the kit and post them in 4.0, it would be much simpler.

0 Kudos
Message 5 of 1,261
(26,464 Views)

hi expertise,

 

anyone can convert the vi for sr760 for me? I can't find a local representative here.  

0 Kudos
Message 6 of 1,261
(26,448 Views)
Upconvert them to what version? Those VIs are written in 3.1, and as noted, you need either the conversion kit, or someone with LabVIEW 4. Besides, have you looked at the driver page?
0 Kudos
Message 7 of 1,261
(26,439 Views)

Hi, I'm using LabVIEW 8.0. I wanna use this vi to perform some measurement on sr760. Yes, I've looked the driver page. 

 

Thanks,

 

 

0 Kudos
Message 8 of 1,261
(26,433 Views)
So why don't you just download the driver from there, which has a version for LabVIEW 8.0 instead of trying to upconvert something from 3.1?
0 Kudos
Message 9 of 1,261
(26,386 Views)
Oh, b/c I'm so stupid.... Thanks!!!:smileytongue:
0 Kudos
Message 10 of 1,261
(26,409 Views)