LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Unexpected Cursor Jumping when Zoomed In on Waveform Graph

Hello,

I'm experiencing unexpected behaviour with cursor events on waveform graphs. I have 2 vertical cursors to select a sub-section of data (signal over time). When I zoom in on one cursor (in order to position it more precisely) and then grab it, the other cursor jumps to a seemingly random position.

How to reproduce (see also attached minimal example):
0. Have a waveform graph with 2 cursors, all of the data and the cursors in view.
1. Select the zoom tool from the graph palette (e.g. X-zoom).
2. Zoom in 1 or 2 times on any cursor.
3. Select the select tool from the graph palette.
4. Here's the unexpected beahaviour: when you grab the cursor now, the other cursor changes position in a seemingly random fashion.
5. If this doesn't happen right away, zoom in some more or reset and try again, it happens at least after 2-3 attempts.

Further details on item "4." above:
- You can see that the bug occurred before even grabbing the cursor: when hovering over the graph, the mouse cursor icon changes to the little cross (the one for grabbing the center of the graph cursor, instead of the line with arrows, indicating the movement on a single axis).
- If the cursor is grabbed, the other cursor changes position immediately. A "Cursor Grab" event is triggered for the wrong cursor, also a "Cursor Move" event, even if the cursor is not moved.

System:
Windows 7 Pro 64bit
LabVIEW 16.0f1 32bit

Maybe someone can confirm that this is unexpected behaviour, or tell me what I'm missing here.


Kind regards

 
 
0 Kudos
Message 1 of 8
(2,309 Views)

I would say yes, it is unexpected behavior.

 

However, I'm not seeing it.  This is with opening it up in LV 17.

Someone with LV 16 should try to see if they can replicate the behavior.

0 Kudos
Message 2 of 8
(2,298 Views)

Hey RavensFan,

 

thanks for the reply. I tried it on a colleague's computer with LabVIEW 17.0f2 64 bit, and I could reproduce the error.

It might not happen right away, so here's what I do to provoke it:

 

1. zoom in (X-zoom) on any one cursor

2. change to select tool

3. check if the mouse cursor changes to the cross (indicating the unexpected behaviour) or the line with 2 arrows

4. change to X-zoom again, if it's not the cross, possibly repeat 2.-4.

5. if it's the cross, I grab the zoomed-in cursor, causing the other one to move position

 
0 Kudos
Message 3 of 8
(2,288 Views)

Okay.  I see what you mean now.

 The important part was the "cross" cursor which pops up when hovering over the cursor point rather than the parallel lines which is there when hovering over another part of the line.  I don't think I noticed the part about the cross when I attempted it the first tim.

 

It did it to me once or twice.  Now I'm having a hard time getting it to happen again.

 

0 Kudos
Message 4 of 8
(2,254 Views)

Hello again,

 

I reckon the error is quite intricate to reproduce, so I attached a little "picture story" that shows the relevant steps. For me, it happens almost always after the third X-zoom on the graph cursor.

 

I feel like the problem doesn't sound very important, but it is rather irritating if you try to position a graph's cursor precisely on a data sample. With a samplerate of 200 Hz or more, that makes for very small dt's, i.e. a high zoom. Also, this makes me wonder if nobody else ever had that problem, working with waveform graph cursors.

 
0 Kudos
Message 5 of 8
(2,230 Views)

Okay,  trying after doing the X zoom 3 times seemed to consistently cause a problem.   When I followed the instructions in the VI of doing after "1 or 2 times on any cursor" it was not causing a problem.  When I had it happen originally, I must have zoomed in more than 2 times and hadn't realized it.

 

It definitely seems like a bug.

 

Hopefully someone in NI follows your  steps, confirms it, then sends either:

1.  "Thanks, we have reproduced it and agree.  Here is a CAR # we have assigned to it."  OR

2.  "Thanks, we have seen this before and already have assigned this CAR # assigned to it."

0 Kudos
Message 6 of 8
(2,217 Views)

Okay, thank you RavensFan for confirming this bug.

 

Dear NI employees, maybe someone can take a look at that.

 

I additionaly found out that this only concerns the "Free dragging" cursor mode. It doesn't happen when a cursor is set to "Single-plot".

Also, I tried a workaround with a "Cursor Grab?" event where I determined if the grabbed cursor is in view at all (XScale.Min <= CursLoc.X <= XScale.Max) and if not, I tried to set the correct cursor positions via property node. This made the cursors move randomly too.

 

So, the best workaround I found for me is to set the cursor mode to "Single-plot", at least as an option (because Single-plot mode doesn't feel intuitive for the user if the waveform graph displays multiple different parallel and successive plots).

 
0 Kudos
Message 7 of 8
(2,209 Views)

Dear Labview-folks,

thanks for publishing this bug.

I thought I was the only one to have this (because I thought it is related to my computer wheresometimes stange things happen like that the context menue is outside the window and not accessible when i work with 2 displays of identical full HD resolution).

Back to the topic:

I can confirm this bug as described as well (for graphs used in an "exe", programmed in LV2016).

I can confirm that it happens with free dragging setting of the cursor.

That the cursor changes to a certain cross type instead of the parallel lines does not happen always before this jumping happens.

However, with single plot dragging mode it does not happen.

The bug is VERY annoying if you have a lot of plots in one diagram and do not want that you always have to change the selected "snap to" plot.

 

Best regards

0 Kudos
Message 8 of 8
(2,194 Views)