LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

ULx driver - "null" as a Dependency

I installed the ULx driver from MCC Measurement Computing.

The driver gets installed in LabVIEW's vi.lib directory.

I don't understand why I am getting a null entry in the test program project.

Capture3.PNG

 

How do I fix this warning? I am wondering whether this has something to do with the ULx driver being previously installed to LabVIEW's instr.lib directory in earlier versions of the driver.

 

There are no broken VIs.

0 Kudos
Message 1 of 4
(1,320 Views)

Can you right click the item and select resolve conflicts? There might be an explanation.

0 Kudos
Message 2 of 4
(1,270 Views)

How many different versions of LabVIEW are on your Development PC?  How many different versions of the MCC Driver Software were installed?  What version(s) are you using for Development?  How did you do the installation?

 

There is additional information on the ULx driver(s) and installation on the MCC Website.

 

If you've got an "installation problem", particularly if you have multiple versions of LabVIEW and drivers, you may want to consider a "clean install", which begins with doing a full Uninstall of NI Software and any "left-over pieces" (such as possibly code from MCC, IVI, VISA) that show up in Programs and Features (hmm -- I forgot to ask what version and bittedness of Windows you are running, as well as whether you have installed 32-bit or 64-bit LabVIEW).

 

Bob Schor

0 Kudos
Message 3 of 4
(1,263 Views)

I only have LabVIEW 2012 (32-bit) installed on this laptop.

However the source code came from a laptop where LabVIEW 2012 and LabVIEW 2017 was installed.

 

It appears from that on that laptop the ULx driver was installed or moved to the instr.lib directory. It may not have been properly installed as in that the files for the driver were simply copied over to the instr.lib directory. And the driver may have been an older version.

 

This problem went away when I removed an unused VI from the project. It was looking for driver VIs from the instr.lib directory and those driver VIs had different terminal types.

 

 

 

 

 

0 Kudos
Message 4 of 4
(1,250 Views)