LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Turn off auto white balance on USB camera

Hi,

 

I'm using a USB camera to capture images of bright colored lights. I have the light configured and working in MAX and Labview 2009. My problem is that the camera is set to auto white balance in MAX and Labview, and I can't seem to change this to no white balance. When the bright lights are imaged the white wall behind the light turns the complimentary color to the light as the software attempts to 'white balance' the entire image. There doesn't seem to be an option in Labview or MAX to turn this white balance to anything other than 'auto.' I've attached the program and a couple screen shots to show the problem.

 

Any help would be appreciated!

 

Download All
0 Kudos
Message 1 of 11
(9,089 Views)

Hi mrainey,

 

What ype of camera do you have and did it come with any software. I have a Logitech USB camera that you have to use the Logitech software to disable the auto white balance.

Joe Daily
National Instruments
Applications Engineer

may the G be with you ....
0 Kudos
Message 2 of 11
(9,068 Views)

It's an Edmund Optics camera, part 59364 on 

http://www.edmundoptics.com/onlinecatalog/displayproduct.cfm?productID=2818&PageNum=1&StartRow=1

 

I've tried to configure the camera in the software that comes with it, which I have been able to do, but as soon as I run MAX or LabView, it seems to override the settings and turn white balance back on.

 

Thanks for the feedback.

0 Kudos
Message 3 of 11
(9,054 Views)

Hi Mrainey

 

Try setting the bayer pattern to none using a IMAQdx property node.

Joe Daily
National Instruments
Applications Engineer

may the G be with you ....
0 Kudos
Message 4 of 11
(9,021 Views)

Joe,

 

I've found the property node, but how can I change the bayer pattern with it? It does not seem to be an option. It only gives me Border Size/Image Size/Image Name/Image Type as the options to be controlled via the property node. I attached my code for reference.

 

Thanks for your help!

0 Kudos
Message 5 of 11
(9,011 Views)

Hi Mrainey

 

I looked at your code and you are wiring the property node to IMAQ image. You need to wire this to the IMAQdx session. You will then be able to access that property node.

Joe Daily
National Instruments
Applications Engineer

may the G be with you ....
0 Kudos
Message 6 of 11
(8,988 Views)

Hey Joe,

 

I tried wiring the property node where you suggested, and was able to turn off the bayer pattern, but this didn't fix the problem. I'm still getting white balancing problem. I'd appreciate any further suggestions, thanks for your help!

 

0 Kudos
Message 7 of 11
(8,973 Views)

Hi Mrainey,

 

I really don't know at this point, my best suggestion is to play with the settings in Measurement and Automation Explorer. 

 

I will esculate to R&D and see if they have any ideas.

 

Joe Daily
National Instruments
Applications Engineer

may the G be with you ....
0 Kudos
Message 8 of 11
(8,967 Views)

Thanks, I appreciate any help!!! Please keep me updated.

0 Kudos
Message 9 of 11
(8,899 Views)

Hi!

 

This might be late, but for the sake of reference I will answer anyway.

 

You should use 2 property nodes.

To the porpery: "CameraAttributes->ActiveAttribute"

you should wire the string: "CameraAttributes::WhiteBalance::Mode", and to the property "ValueDBL" you should wire 1 (for manual).

Then repeat this on a second property node but change "mode" to "value" and wire the desired value to "ValueDBL."

 

For a more complete description see my post on a similar problem with autofocus (change "Focus" to "WhiteBalance" and it is the same as described above).

http://forums.quickcamteam.net/showthread.php?tid=891

 

// Emil

 

Message 10 of 11
(8,639 Views)