LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble with using HP34401a.lib to control HP34401a multimeter through serial port

I am using HP34401a.lib, which is coming with LabVIEW distribution CD, to control HP34401a multimeter. If I choose GPIB, it works fine, but if I choose serial port to control the meter, then I got the following error message:
Error-1073807246 occured at OLD VISA Open in HP34401A Initialize.vi -> HP34401A Getting Started.vi
Possible reasons:
VISA:(Hex oxBFFF0072) The resource is valid, but VISA cannot currently access it.
In another occasion I also got the following error message:
Error-1073807331 occured at Property Node (arg 9) in HP34401A Initialize.vi -> HP34401A Getting Started.vi

I don't know what I should do to correct those errors. Any suggestion is highly
appreciated. The serial port and cable has been tested with Loopback.vi, it works O.K.
0 Kudos
Message 1 of 7
(1,717 Views)
As far as the first error, VISA cannot access the serial port if another application has it open. Make sure that you don't have something like hyperterminal open while you're trying to the driver. The second error is "The specified attribute is not defined or supported by the referenced resource." and I would check to see if the version of VISA that you're using is up to date. You might try removing arg 9 which I think sets the DTR line.
0 Kudos
Message 2 of 7
(1,717 Views)
Hi Dennis,
Thank you for your help. Could you please tell me how to remove arg 9. I tried to remove DTR, but I got broken arrow on vi.
-Lu
0 Kudos
Message 3 of 7
(1,717 Views)
By setting the Flow Cntrl of the property node from DTR/DSR to None, actually I got rid of the complain about "arg 9". Now no more error on the DTR line, but I still cannot get the reading. On the LED screen it did display Rmt after I hit the run arrow, it means some communication between HP34401A Getting Started.vi and the multimeter is going on, but the read operation is not right, the new error message reads as follows:
Error-1073807339 occured at VISA read in HP34401A Control Mode.vi->HP34401A Initialize.vi->HP34401A Getting Started.vi, Possible reasons: VISA Time Out expired before operation completed.
I am a newcomer to the LabVIEW, any suggestion is fresh to me. Many thanks in advance.
0 Kudos
Message 4 of 7
(1,717 Views)
The only thing I can suggest is that you check to make sure that the serial port of the instrument is set the same as what the driver is setting the comm port of the pc.
0 Kudos
Message 5 of 7
(1,717 Views)
from what I have seen, you have to go into the vi and manualy switch over to serial, also on the HP, you have to set it to rs232 instead of a gpid address
0 Kudos
Message 6 of 7
(1,717 Views)
I have the same problems with LV6i ,RS232 and HP34401.
I don't know why,
I have tried to set the ID Query (Initialize.vi) on "Don't Check" -> no result
Setting the Flow Cntrl on NONE -> Error 1073807360 at "VISA OPEN" (open.vi New or Old) in Initialize.vi
The cable is Ok, because it works on the PC with Win98 (LV6i, RS232, Hp34401a the same Programm ) !!!
Why it dos not works with win2000 ?!?!?
Have you any answer?
0 Kudos
Message 7 of 7
(1,717 Views)