LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble connecting USB Mic to LabView via MAX - Win 10

Dear LabView Community,

 

I hope you have some advice for me on how to proceed with the following Problem:

 

Background: I am new to LabView and want to work myself into the topic.

Apart from the programming which I assume is quite fun (for me), I have troubles getting started with the whole program as whole I guess:

 

I just wanted to do the tutorial with my Microphone and I already struggle connecting it, or make it visible for LabView. It's the Sennheiser PC 8, quite a crappy standard mic for which I didn't find a driver.

 

I tried to add it via MAX, but the program doesn't find it (the tutorial says "refresh" so you can see it...). I didn't work before on such a basic programming level where I would have to deal with driver issues in a way that I would have to "create" them myself or would have to dive pretty deep into the system itself (just for info).

 

Okay - so I figured out I would have to do a little more than that. The problem is, that in the device manager the microphone has no COM Port, at least I don't see it. So when I want to add the device via MAX by serial and assigning a COM port, that doesn't work.

 

Now I tried to use NI-VISA Driver Wizard to create a driver for the device. Apart from an error message at the beginning (Error - 1073807175: bLength field is incorrect for USB_ENDPOINT_DESCRIPTOR type) I can create a USB driver for my device. Yet the installation from the Wizard doesn't work and the (tells me may be I should do it as admin but that doesn't work either).

The *INF file only provides "Windows 8 installation" help... is the Wizard not at all compatible with WIN10? I am even not provided a code like "INFWin10" to use on the NI site... a folder like "Windows Kits" doesnt excist in my program data directory (which would have to be there for WIN8 following the instructions on the site: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019L9QSAU )

 

All I want is my Mic device to show up in MAX to add it into my LabView Program.

 

Also I am grateful for some comprehensible "getting started" guide that deals with basic issues like that for LabView... e.g. which programs I need on top (which driver packages, NI-VISA / MAX / etc....)

 

I have LabView 2016 & 2017 installed.

 

I am looking forward to you help, I would appreciate it alot.

Best - hubie

0 Kudos
Message 1 of 2
(2,449 Views)

Okay, just to clarify:

 

I simply want to connect my USB microphone to my PC and add the device via MAX to LabView.

That doesn't work. I tried several approaches:

 

1.) Plug in the device while MAX is opened and refresh devices afterwards. Sadly, no effect. Uninstalling the device driver before unplugging and plugging in again also no effect. (similar question with a USB scope here: https://forums.ni.com/t5/LabVIEW/MAX-doesn-t-find-my-USB-Scope/td-p/2435628 )

2.) Creating a device driver via NI-VISA... he tells me that another driver may already have been installed (which is the case because Windows installs the default driver) and he creates an *INF file.

Signing this file via the Windows Developer Kit (WDK) by using "INF2CAT" - which would be the next step to "install" the driver created by NI-VISA - doesn't work (tutorial: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019L9QSAU ). He is missing several entries in the *INF file, I don't know about this yet I guess. On top I think this is a dead end, as there is already a workable driver from Windows.

3.) There is a tutorial on how to let USB devices show up in MAX if they initially don't: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019La2SAE

I followed these steps and found the "austbmc.sys" file, but Windows just tells me, that the best suited driver is already installed 😕

 

Are there simply some instruments (like my crappy USB Mic) that cannot be used with LabView? Or do I need to write a driver myself??

In the device manager I can look up the driver details which gives me the directory of the files that compose the device driver... Is there a way to tell LabView what the device driver files are so MAX can make sense of it?

I am just afraid I am missing something basic here, so when I connect my fancy scientific camera (which I haven't purchased yet) to the PC, MAX still won't get it...

 

Currently there are no devices showing up in MAX, despite an empty "network devices" branch 😞

 

Best - hubie

 

0 Kudos
Message 2 of 2
(2,420 Views)