LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

To much data?

Hi everyone,

 

I’d better start right away… This is my problem this time:

 

I want to do some analyses with LabView. Analyses on frequency spectra.

 

I got raw data from some force measurements. It’s a measurement with an high sample frequency so there are a lot data points. Normally the measuring file is an .smr file. But I can also save it as an .txt file. I added a .txt file. The .txt file contains over 210.000 separate measured values.

 

I found out that this .txt file might be to big to read into LabView. When I cut the measure file into pieces I get the same signal as on the measuring program (which is NOT in LabView). I got the feeling that it eliminates values within between.

 

I’m using LabView 7.1. Could somebody please have a look at this problem? Just to make sure that I can use the big data txt file, because I’ll have to analyse over 130 of them, so cutting it into pieces is not a good option!

 

I added a big and small txt file!

 

Many thanks in advance!

0 Kudos
Message 1 of 16
(1,066 Views)

With the Read From Spreadsheet File function, I can read either file with very little noticeable difference in the time it takes to read.

Message Edited by Dennis Knutson on 01-11-2007 11:29 AM

Message 2 of 16
(1,056 Views)
Oh shit, I added the wrong data files!!!!!!!
 
Check the same again plz:
 
 
0 Kudos
Message 3 of 16
(1,045 Views)

I still don't have any problems. The large one takes about 3 seconds to load on my pc. Exactly what problems are you having?

 

Message Edited by Dennis Knutson on 01-11-2007 12:37 PM

Message 4 of 16
(1,043 Views)
my problem is that i can't get the graphic you have at the first image...
 
I get a look a like graphic, but than flattend at the top. So it's a sort of block wave as you wish.
 
But The first image looks awesome!
 
but how did you do that?
0 Kudos
Message 5 of 16
(1,037 Views)
The entire program is what I attached. The graph is just a resized default Waveform Graph. If you want your program fixed, you should attach it so someone can look at it.
Message 6 of 16
(1,031 Views)
That's a thing that i don't iunderstand... My programm has the same beginning... I Attached it, could you please have a look at it? That would be really helpfull!
 
Many Thanks
0 Kudos
Message 7 of 16
(1,022 Views)


@MrHond wrote:
I get a look a like graphic, but than flattend at the top. So it's a sort of block wave as you wish.


It looks like you have a problem with localized decimal point (options...front panel). The small files contain a comma as decimal seperator while the large file contains a period, so you might only get the integer part depending on your localization settings.

What country are you in?

 


LabVIEW Champion Do more with less code and in less time
0 Kudos
Message 8 of 16
(1,018 Views)
I'm now in the UK, Oxford Brookes University,
 
But i'm working on a Dutch laptop, that's where i'm originally from
0 Kudos
Message 9 of 16
(1,011 Views)
Hoi Martijn Smiley Happy,

You should use the following formatter:


Have a special look at the %,; it will treat the ',' as the decimal sign!
Have a look here.

Ton

Message Edited by TonP on 01-11-2007 09:16 PM

Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep www.lvug.nl
My LabVIEW Ideas

LabVIEW, programming like it should be!
0 Kudos
Message 10 of 16
(998 Views)