Showing results for 
Search instead for 
Did you mean: 

Tips on transferring LV executable that uses Field Point Serial to another PC

I have been trying to transfer an LabVIEW compiled executable  from one PC to another

The executable references 2 field point serial banks.


After hours of frustration I think I have it pinned it down to the fact that (at least for me) It is not possible unless LabVIEW is invoked on the target machine.

Only if I start LV 2010 and configure a field point control on it then LabVIEW can refer to the Bank. After that I can have it refer to the correct IAK file and the executable will work. 


However IF I try to transfer from another machine without starting LabVIEW on the target machine it simply will not work for me.

It seems that I have to load a FIeld point control on a block diagram of a new machine then configure it to get dialogs to come up specifying

how to select the proper configuration. I do not see any of this help in MAX


Id much rather have a way of setting up in MAX than having my EXE work right away. Instead my workaround is to

start LabVIEW and configure a field point control to get it set up proiperly.

This means I may have to install yet another version of LabVIEw to get the exe to work again and its getting tiresome.


I use INI files for the serial port settings. Its the field point software that has me going in circles.


If anyone have any experience or tips for transferring an executable that uses fieldpoint serial (FP-1000) from one PC to another PC

without having to invoke LabVIEW to configureit I would be interested in hearing from you. Thanks



PS Target machine has LV2010   MAV ver 4.70f4

Executable compiled in LV 2010


Source Machine has LV 2010 SP1  MAX ver 4.7.6

Executable compiled in LV 2010 SP1


My next move is to upgrade the target to 2010 SP1 and try again but it has already taken me days to transfer this one program

and I still cant figure out how to do it so I might just wait and see if there is any interest in helping me first.


Thanks again!







0 Kudos
Message 1 of 11


I have been to these KnowledgeBase links and what is so frustrating about it is that I have have not seen anything that was not already done

automatically when I created the executable on the source machine and transferred the executable to the target machine.



MY FP version is 6.07 on both machines.


The dll is where its supposed to be on the target machine in a Data subfolder under the main application (exe) folder


The IAK file is created in MAX with the designations identical to what is the source machine.



The EXE is now partially working (somehow) but I am trying to find out the exact procedure for next time so I can write it down for future reference..


EVen though the target application now 'sees' the Field point banks the utility I added into the exe to allow user to configure a front panel Field Point control

(should it be required) does not work. Instead when I try to browse configure the control in the executable I now get this error dialog.

This must be the root of all my troubles.


I am now attempting to resolve this by installing LV2010 SP1  and DCD_NOV10 on the target machine so that it matches the source machine.

(If I am going to re-install Fieldpoint I might as well install the whole Device Driver CD)


I hope this solves this issue once and for all.


Your knowledge base insists that if the field point versions are the same on both machines and if the DLL is where it is supposed to be and if the IAK file is loaded and saved

this should work. It did not and still does not fully work. If I can find the exact reason I will report it in this thread.







0 Kudos
Message 2 of 11


For clarification of the question posed, could you please provide the following information:

1.) How are you transferring files from one PC to the other? Installer perhaps?

    1a. If you are using an installler, are you including drivers such as NI-Serial, NI-VISA   
        and NI-Field Point

2.) How are you referencing the iak file used to configure the Field Point? Are you using an iak file that is part of the original project or are you using an external iak file?

3.) Are the serial and COM port names on both machines the same on the original and current PC? Are you using a front panel control to select the COM resource?


Patricia B.

National Instruments
Applications Engineer
0 Kudos
Message 3 of 11

Thank you for answering Patricia,


I finally solve this problem by installing a complete copy of LabVIEW 2010 and then configuring a field point control on a front panel.

in LabVIEWs edit mode. While this requirement is ridiculous I was trapped into doing it this way because nothing else worked for me.


The dialogs that provide a browse function for a field point control (for the first time i assume)  simply do not exist in an executable created on the target machine.


Let me be clear. After installing LabVIEw and the entire CD set of device drivers I still could NOT get a simple executable that i made to test Field Point serial this to work. The exe had nothing but a simple field point control on a front panel in a while loop with a stop button.


It was not until I actually configured a field point control on a front panel in LabVIEW >>>>in edit mode <<<<< that it was able to make the link.


I hope that is clear.

I realize there could be a million reasons for this behavior but that is exactly what I had to deal with.

Thanks for attempting to look at this







0 Kudos
Message 4 of 11

Sorry for delay in providing more info

Here is the technical info on source and target.

I am just looking for (for next time) tips on how to transfer my executable to a "vanilla" XP 32 machine with the NI 16 port serial card installed.


Also was the test I did valid? (Having single FP control on a front panel with a while loop and a stop button built into an executable )


Should the browse feature of a field point control reference be available in an executable? IF yes what if anything could I be missing?

Thanks again.





0 Kudos
Message 5 of 11



To clarify, your questions refer to a Field Point setup but your attached image is of a PXI chassis? My apologies, but I'm not sure I understand the hardware setup.



National Instruments
Applications Engineer
0 Kudos
Message 6 of 11

Sorry for delay


Yes the source is an NI PXI chassis with embedded Pentium CPU and PXI 16 bit serial card.

(NI-PXI-1031 with an NI-PXI-8105 card in it for the serial ports)


This PXI-1031 is starting to fail from heat related graphics issues. That is the reason we are trying to transfer to another PC as a backup.

(8000 dollar investment btw)


The target would be any Dell class 32 bit win XP CPU with an NI-PCI-232 card in it.


I just ned to know how can I make it so that when the exe is first run it is possible for

an administrator to make the initial link to the field point units through some configuration utility.


 I could not find any way to do this in an executable. Therefore I was forced to install a complete copy of LabVIEW along with Visa and Field point drivers, then I had to use the browse feature of a front panel Field Point control placed on the front panel (or constant) in LabVIEW. This was the only way I could make the initial link, understand?  It did not work in an executable as I would have expected. This is the reason I am asking what if anything I may have done wrong.

Thank you







0 Kudos
Message 7 of 11

Hi John,


Have you tried building your application with the following KB? See question 4




Che T.
Applications Engineer
National Instruments
0 Kudos
Message 8 of 11



Did you ever figure out the fieldpoint browse issue?  I am having the same problem with my executable!




0 Kudos
Message 9 of 11

Hey Diana, 


Looks like this is your first time posting on our forums. Welcome and thanks for posting!


Could you elaborate some on the issue that you're having? I know you said its the same as one of the users above wrote but I was hoping you could just explain it a bit further as this is kind of an old thread. Were you able to take a look at the link Che T. added above? Step 4 in this document presents a good way to handle distributed IAK files to multiple computers. 


Hope this helps you a bit. And again, welcome to the forums!

Tim A.
0 Kudos
Message 10 of 11