LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

The pop up menu of “VISA resource name” comes nothing except refresh.

I need help!

I connect the Agilent 33220A to my computer through Agilent 82357B USB-GPIB cable. Both Agilent connection expert (Agilent IO control) and NI-MAX can detect the equitment and query the *IDN? successfully. I when I want to use the driver example in lab view 2015 (Agilent 33xxx series), the pop up menu of “VISA resource name” comes nothing except refresh.

lab view front.png

I already reinstall NI-VISA driver even the whole Lab View package, but it not work. Below shows my MAX (GPIB::10::INSTR is 33220A).

QQ截图20160927185852.png

QQ截图20160927185852.png

0 Kudos
Message 1 of 30
(2,629 Views)

Check whether GPIB Interface drivers are installed while installing Device Drivers?

Pazhanivel Thiruvenkadam,
CertifiedLabVIEWArchitect|| CertifiedTestStandDeveloper,
Currently able to Access LV2015&LV2017
0 Kudos
Message 2 of 30
(2,597 Views)

Install the drivers from here and then see if it works: http://sine.ni.com/apps/utf8/niid_web_display.download_page?p_id_guid=0470714759413BCCE0440003BA7CCD...

Thanks
uday
0 Kudos
Message 3 of 30
(2,592 Views)

Right click on the VISA control and check what settings are present under I/O Name Filtering.

0 Kudos
Message 4 of 30
(2,582 Views)

Hi Peter,

 

what happens when you replace the VISA IO control with a simple string constant containing "GPIB0::10::INSTR" (without the quotation marks)?

Best regards,
GerdW


using LV2020 on Win8.1+cRIO
0 Kudos
Message 5 of 30
(2,578 Views)

It shows this

QQ截图20160928111152.png

 

Now the situation is both MAX or Agilent IO can find 33220A, but in Lab View, it can not find 33220A, I do not know why and what should I do.

 

Please help!

 

0 Kudos
Message 6 of 30
(2,548 Views)

Follow Ravens Fan's advice

Capture.PNGCapture1.PNG


"Should be" isn't "Is" -Jay
0 Kudos
Message 7 of 30
(2,543 Views)

Thanks for answering me.

I bought the 82357B USB-GPIB cable, and installed the Agilent IO control software, Is it the GPIB interface drivers?

I can query *IDN? successfully and MAX also can find USB-GPIB, is it means the USB-GPIB works well?

The problem is that the labview program can not find it.

-------------------------------------------

Thanks for you remainder.

0 Kudos
Message 8 of 30
(2,541 Views)

I also have the same setting, but it not work.

0 Kudos
Message 9 of 30
(2,537 Views)

@PeterChen wrote:

I also have the same setting, but it not work.


If you are refering to the settings shown in my second capture in my last post.  It won't work! share a snip of your settings


"Should be" isn't "Is" -Jay
0 Kudos
Message 10 of 30
(2,533 Views)