Showing results for 
Search instead for 
Did you mean: 

The pop up menu of “VISA resource name” comes nothing except refresh.

It is the same I already used.

0 Kudos
Message 11 of 30


0 Kudos
Message 12 of 30

To might just try typing in the VISA resource name, as it appears in NI MAX, into the LabVIEW I/O control.


Additionally, you might want to look at the following KB. The attached VI is nice for figuring out what available VISA resources you have in LabVIEW.

0 Kudos
Message 13 of 30

Have you tried this?

Now Using LabVIEW 2019SP1 and TestStand 2019
0 Kudos
Message 14 of 30

It looks like there might be a driver for that on IDNet, have you tried it? It's possible that it'll sort out incompatibilities.


Keysight Technologies / Agilent Technologies hp3562a Analyzer

Staff Software Engineer
0 Kudos
Message 15 of 30

What is really begining to feel funny (funny strange, not funny ha-ha) is this excerpt from the OP:


I wonder what a "Miscellaneous VISA Resource" is and, why it would have the same resource discriptor as the problematic device.  Yes, of course I looked it up in the help file.  The search returned 1 match that was an empty page and, sometimes this error (not even a "This Page intentionally left blank")  MAX 16.0 Help file:



Digging through NI's KB yields this: suggesting the Advanced IO container filter property "Allow Undefined Names" may need to be set before the resource discriptor can be manually entered.



The property is set by default but, with the driver shown comming from the ID Network with plenty of history behind it it should be looked at and verified.  And seriously double checked since the FP Snip the OP has provided does NOT match the FP from the 8.2 version of of the driver from the IDNetwork (Figuring 8.2 version based on copywrite dates)

"Should be" isn't "Is" -Jay
0 Kudos
Message 16 of 30

Now, I just change the name into GPIB9::10::INSTR,



And I run the program showed below:---the program can run (no error), and 33220A reset!


But when I run the program below, the program can run (no error), but I can not get corresponding string (String indicator showed nothing)



Based on these two programs, probably 33220A can get commands from my computer and do the coresponding reaction, but can not send imformation back to my computer. 



Agilent interactive IO still can query successfully.




VISA resource name sometimes (It sometimes can be found when I reopen 33220A--weird) can find GPIB9::10::INSTR, but when I run the program, error occurs.




Does anybody know how to do further?

Many thanks!

0 Kudos
Message 17 of 30

Do you have the termination character included in your IDN? string?

0 Kudos
Message 18 of 30

I already allowed this

0 Kudos
Message 19 of 30

@RavensFan wrote:

Do you have the termination character included in your IDN? string?

Missing termination woul give a timeout error not the error shown.


Lets see a snips of "MAX>>Tools>>NI-VISA>>VISA Options Passports and Conflict Manager pages


"Should be" isn't "Is" -Jay
0 Kudos
Message 20 of 30