LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

The compilation tools are not installed.

Currently I keep getting the attached error when I try to compile the VI. I am have already installed the xilinix compile tools as according to this link, http://digital.ni.com/public.nsf/allkb/A4B20D58C051DFB386257A56007BB0B2. Meaning that I have both installed the 14.4 version and the 10.1 version since I am running Labview 2013 Sp1 and my hardware is the cRio-9074. Is there something else I have to do with the tools other than install them and reinstall Labview FPGA and Labview 2013 SP1? 

0 Kudos
Message 1 of 5
(2,196 Views)

The cRIO-9074 needs the Xilinx Compile Tools 10.1.  Are you sure you installed that tool for 2013?  NI keeps having to make small updates to it for each LabVIEW release.  If you followed the link at the bottom of that page you referenced, you should have the right one.

 

But that error is about the compile server.  Maybe Windows is blocking the compile server.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
Message 2 of 5
(2,150 Views)

I'm having a similar problem. Using Labview2014  and the Crio 9074.

In the indicated page the use the expression: Minimum Compile Tools Version

"The cRIO-9074 needs the Xilinx Compile Tools 10.1." Is this definitif?

So all I need is the 10.1 or the 14.7,Vivado 2013.4 as well? Or the other way why I need the 10.1 when I guess the  14.7 Vivado is the latest compile tool? Do both of the compile tools have different functions?

0 Kudos
Message 3 of 5
(1,940 Views)

Maloya,


You just need the Xilinx 14.7 Compile Tools.

 

The R-Series cards at the bottom of that page (Virtex-II chips) are the only targets which require Xilinx 10.1 regardless of LabVIEW version.  If the minimum compile tools are Xilinx, stick with Xilinx Compile Tools.  Vivado 2013.4 and Xilinx 14.7 are different tools so you do not need both of them.  Newer devices use the Vivado tools instead.

Matt J | National Instruments | CLA

GCentral
Message 4 of 5
(1,932 Views)

I didn't see this page mentioned yet, but this will say what version of what tools are needed for specific hardware.

 

http://digital.ni.com/public.nsf/allkb/02EBA6105D04A1E686257D4E00144C92

0 Kudos
Message 5 of 5
(1,922 Views)