LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

The Hardware and Software do not communicate each other

Solved!
Go to solution

Dear NI Community, 

My name is Sophat Houn, a master student in Photonics and Applications Lab. in Royal University of Phnom Penh, Cambodia. I encountered the problem that " 

Error opening resource:
ASRL10::INSTR

VISA: (Hex 0xBFFF0011) Insufficient location information or the device or resource is not present in the system." when I am trying to open the VISA Test Panel in NI MAX 14.0. I used LabVIEW 2009 SP1 in window 8.1 Single language. If I can not configure this port, I could not control between LabVIEW and the stepping motor controller Model D120 SURUGA SEIKI because this controller used RS232 port and I used the NI USB-232 connector with serial number: FF7BB1 to plug in my computer.
I really need your solutions and advices because my work depend on this!!!🙏

 

I absolutely welcome every solution and advice from the Community. I will put the pictures below to make more understanding about my problem. 

0 Kudos
Message 1 of 8
(229 Views)
Solution
Accepted by topic author Sophat26

First, keep calm 😉. It's not that serious. First, ASRL10::INSTR is not a serial port and you should not bother about it (it's the old fashion parallel printer port).

From your picture, it seems that your real interface is the USB serial port, which has COM3 as an alias. Since there is another COM3-like device, I would make an effort to configure the USB RS232 with another COM port number (e.g. COM5), to avoid conflicts. This is probably to be done with Window's Device Manager.

Paolo
-------------------
LV 7.1, 2011, 2017, 2019
0 Kudos
Message 2 of 8
(219 Views)

Dear really thank for your solution, 

I already change my RS232 UBS serial port to COM5 on Device Manager as you recommended. Screenshot (4).png

As shown as in the picture, and immediately it appear the another port name ASRL5::INSTR "COM5" also. So I click on that port and go to VISA test panel and it appear as shown in the picture below 

Screenshot (6).png

But in my scanning program, I choose the COM5 port as shown Screenshot (7).png

 But when I run this program, it still appears as an error as shown in picture. Screenshot (8).png

So how could I solve this problem? Thank you in advance!!!🙏

Best regard, 

Sophat Houn 

0 Kudos
Message 3 of 8
(155 Views)

Hi Sophat,

 


@Sophat26 wrote:

But when I run this program, it still appears as an error as shown in picture. 


You cannot use the same serial port twice in parallel.

Close the other program which accesses that COM port…

Best regards,
GerdW


using LV2016/2019/2020 on Win8.1/10+cRIO
0 Kudos
Message 4 of 8
(143 Views)

Excuse me, could you give me more solutions or more elaborations on the advice that you stated above because it really hard for me to figure out?

I'm looking for your good advices on this!!!!

 

Best regard!!!,

Sophat   

0 Kudos
Message 5 of 8
(112 Views)

Dear Community,

I meet the problem as shown in the picture.Screenshot (8).png

 

How could I solve it?

I'm looking for any solutions for this !!!🙏

 

Best regard!

Sophat 

0 Kudos
Message 6 of 8
(121 Views)

Hi Sophat,

 


@Sophat26 wrote:

Excuse me, could you give me more solutions or more elaborations on the advice that you stated above because it really hard for me to figure out?


No need to start new threads for the very same topic, please keep things in one place…

 

When the VISA resource is valid, but not accessible, then another tools/process is occupying that VISA resource.

You need to close/end that other tool so it frees the VISA resource, then you should be able to access it from LabVIEW (or MAX)…

Best regards,
GerdW


using LV2016/2019/2020 on Win8.1/10+cRIO
Message 7 of 8
(100 Views)

Dear GerdW,

My problem have been solved now, so thank you so much for your really good advice to me. 🙏

Best regard,

Sophat Houn

0 Kudos
Message 8 of 8
(68 Views)