LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Talk to Agilent E5071C through TCPIP

I try to talk to Agilent E5071C through TCPIP. The setup is

 

PC --- Router -- Agilent E5071C.

 

I could ping the device, but could not detect it using NI MAX.

 

Any suggestion?

 

Thanks,

 

Ott

Message 1 of 9
(5,185 Views)

MAX will not automatically detect TCP/IP instruments. You have to add them yourself. You have to right-click on "Devices and Interfaces", select "Create New" and then select "VISA TCP/IP Resource". Follow the prompts to add the instrument to MAX.

 

This is not absolutely necessary, though, if you're going to program it from LabVIEW, as you can simply specify the IP address in the VISA resource name. Adding the instrument via MAX allows you to give it an alias.

 

If you have not already done so, be sure to download the driver: http://sine.ni.com/apps/utf8/niid_web_display.model_page?p_model_id=5692

0 Kudos
Message 2 of 9
(5,178 Views)

Hi,

 

Pls. see the attached file. I did manually config the port. Still could not talk to it.

 

Any comments?

 

Thanks, 22615i3E1E9CDA66C36CB7

0 Kudos
Message 3 of 9
(5,167 Views)

Did you install Agilent VISA? If so you should re-install NI-VISA.

0 Kudos
Message 4 of 9
(5,162 Views)

I did not install Agilent Visa yet. I am not sure should I install it or not.

 

Should I install Agilent VIsa?

 

Thanks,

Bing

0 Kudos
Message 5 of 9
(5,154 Views)

No. What type of tcp/ip connection did you select (i.e. VXI-11, raw)? What does Agilent say you are supposed to use? You're given three options. Did you try all 3?

0 Kudos
Message 6 of 9
(5,133 Views)

There is not much information in the doc from Agilent.

 

I used a GPIB/USB cable to by-pass the issue. It's working now.

 

Thanks for help,

 

Ott

0 Kudos
Message 7 of 9
(5,081 Views)

I believe the problem with the lack of VISA TCPIP Connect String is setup incorrectly on the E5071C device. The E5071C device has the string set to TCPIP::192.168.100.122::INSTR on the internally hosted webpage but the NIMAX VISA is trying to use the TCPIPO::192.168.100.122::INSTR string, which is hard-coded in NIMAX. Keysight needs to change the connect string on the instrument. I put in a ticket with Keysight to verify this.


@Ottawa_T 

 

0 Kudos
Message 8 of 9
(4,139 Views)

I heard back from Keysight. You have to enable the SICL/LAN server in the E5071C:

 

System > Misc Setup > Network Setup > Enable [ON]

 

E5071C_SIC_LAN_Enabled.jpg

0 Kudos
Message 9 of 9
(4,095 Views)