LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

TCP/IP over Internet

Solved!
Go to solution

@altenbach wrote:
DMZ is not used here in the classic way. On cheap consumer routers, a default forwarding rule that forwards all ports not otherwise defined to a specific IP is sometimes incorrectly called DMZ.

Thanks, haven't run across that in the routers I have been using.  So if it is setup for all forwarding then it should allow connections both inside and outside the private network.  Still haven't gotten an answer if it works in either of those modes and exactly what is being tested.

 

Telnet will at least tell you if you can connect on a given port and if your firewalls/DMZ is set correctly.

 

0 Kudos
Message 21 of 32
(521 Views)

This is very very very difficult, as launching a rocket to the moon !! 

 

Well, I will post all information about what I´m doing in the last test!

 

#1 My office computer is running labview, the example called "TCP Communicator - Passive", which is basically a TCP server.

#2 I have set a static IP for my office computer (192.168.0.120), and its set correctly as I can get internet connection. 

#3 The router has configured "Virtual Server" for 192.168.0.120, for inbound ports 8000-9000 and outbound ports 8000-9000. Port forwarding are also configured for 8000-9000

#4 My personal computer is at home, where router is not configured, and runs labview, the example called "TCP communicator- Active", which is basically TCP client. 

#5 My office computer runs as TCP server with port 8899

#6 My home computer runs as TCP client with port 8899 and address 5.154.114.180 (my server public IP).

 

The results: 

 

Server gives timeout

Client gives Error 63 occurred at TCP Open Connection in TCP Communicator - Active.vi (Buffer overflow).

 

What am I doing wrong !?!? More configuration is required? Maybe client configuration needs port forwarding too ?

0 Kudos
Message 22 of 32
(518 Views)

Now we are getting somewhere.  This is a fairly simple setup and going to the moon is harder.

 

When you are at home and ask the client to connect to the server.  What address do you give the client to use as the server to contact?  It needs to know where to find your office on the internet.  The internet is a big place!

 

This address will be the WAN or public address of the office router that you configured.

 

There is no forwarding for the client (home computer) since there is no routing or DMZ.  All packets going to the client will go directly to your home computer with no routing.

 

It sounds like your office computer is set up correctly.

0 Kudos
Message 23 of 32
(514 Views)

The client, I use public IP of the server to contact to. Is it correct? Ports are 8899 for client and server both! OK ?

 

Why I get error 63 buffer overflow in the client computer at home??

0 Kudos
Message 24 of 32
(512 Views)

To be more precise, 

 

The client computer (Home) receives: 

Error 63 occurred at TCP Open Connection in TCP Communicator - Active.vi

Possible reason(s):

LabVIEW: Serial port receive buffer overflow.
=========================
LabVIEW: The network connection was refused by the server.

 

The server computer (office) receives:

Timeout !

0 Kudos
Message 25 of 32
(505 Views)

@castek89 wrote:

The client, I use public IP of the server to contact to. Is it correct? Ports are 8899 for client and server both! OK ?

 

Why I get error 63 buffer overflow in the client computer at home??


It is not a buffer overflow.  Read the message carefully:

Error 63 occurred at an unidentified location

Possible reason(s):

LabVIEW:  Serial port receive buffer overflow.
=========================
LabVIEW:  The network connection was refused by the server.

 There are multiple reasons for a '63' error code.  Since we aren't dealing with a serial port then I assume it is the second definiton.  "The network connection was refused by the server."

 

0 Kudos
Message 26 of 32
(504 Views)

Why !?!?!? Why !? hahaha Ports are not propperly opened ? Server is not active?

 

 

0 Kudos
Message 27 of 32
(495 Views)

Can you attach the two VIs you are using?

 

Port forwarding is not needed for outgoing connections.

Don't create outbound rules.

Don't configure virtual server and port forwarding in parallel. They serve the same purpose.

Did you configure the windows firewall to allow incoming connections from public IPs? (see picture of the default settings, which only allows local connection)

 

 

Do a couple of wireshark packet captures to see what is going on.


LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 28 of 32
(485 Views)

I had to leave for an executive committee meeting....  Gets in the way of programming....

 

All good suggestions from Christian.  From your home computer can you "ping" the office computer?

 

What network tools do you have?

0 Kudos
Message 29 of 32
(473 Views)

It appears that at least the home computer that you have mentioned at 5.154.114.180 is either down or does not respond to ping.

 

But it is up at least to respond to ports 20 and 22 (telnet and ssh), this means that some sort of routing is going on.  Not sure what else, and I stopped my scan at too low of a port.  I will do a full scan of all ports.  (0-65535)

 

If you want to PM me with the address of your server I can scan that as well to see if the server has that 8898 port open.

0 Kudos
Message 30 of 32
(467 Views)