LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

TC01 Timing

Hello,

Just installed trial version of LV home edition. I used a CD I had from 2015 to load the NI Device Drivers, every thing looked good at install. I connected a brand new USB-TC01 thermo couple interface (arrived today) Started LV and droped a DAQassist on the BD for a quick test, configured the parameters and tried to save the configuration. I get the error  "Firmware for the device is too new." " Downgrade the firmware for this device."  OK downgrade it to what? and how?  This is on a win 7 laptop.

 

Thanks for any help!

 

Alan

0 Kudos
Message 1 of 7
(1,742 Views)

Hello,

Just installed trial version of LV home edition. I used a CD I had from 2015 to load the NI Device Drivers, every thing looked good at install. I connected a brand new USB-TC01 thermo couple interface (arrived today) Started LV and droped a DAQassist on the BD for a quick test, configured the parameters and tried to save the configuration. I get the error  "Firmware for the device is too new." " Downgrade the firmware for this device."  OK downgrade it to what? and how?  This is on a win 7 laptop.

 

Thanks for any help!

0 Kudos
Message 2 of 7
(1,739 Views)

Sorry, I double posted this. Couldn't see ow to delete.

 

Sorry again

 

Alan

0 Kudos
Message 3 of 7
(1,738 Views)

Hi Alan,

 

you should have received a CD/DVD with your TC01, which contains suitable hardware drivers (aka recent version of DAQmx). Did you install this?

 

Or else try to download the current DAQmx version from NI website and install this. It will be compatible with your LV2015 installation - I hope: never worked with Home edition.

When you have bought the TC01 from NI: call the support to help you with your problem!

Best regards,
GerdW


using LV2020 on Win8.1+cRIO
0 Kudos
Message 4 of 7
(1,723 Views)

No drivers came with the TC01,  I am confused by the error msg to "downgrade the device"   LV home is on LV 2014 , The drivers I loaded are from 2015 so newer, and should work? The device says to use DAQ mx 14.5 or higher and I am. Still confused.

 

Alan

0 Kudos
Message 5 of 7
(1,701 Views)

You are not the first to be confused!

I forget specifics so I'll point you to the search results, best of luck.

The TC-01 is a neat little device on it's own, but has firmware/driver versions issues.

 

http://search.ni.com/nisearch/app/main/p/bot/no/ap/global/lang/en/pg/1/q/TC-01%20firmware/

 

-AK2DM

~~~~~~~~~~~~~~~~~~~~~~~~~~
"It’s the questions that drive us.”
~~~~~~~~~~~~~~~~~~~~~~~~~~
0 Kudos
Message 6 of 7
(1,684 Views)

I think this is what you need.  I recently tried getting an old TC-01 working on a newer system and couldn't for the life of me figure out how to update the firmware.  Turns out NI made a special tool for this type of hardware which is updated in a way different than most NI hardware.

 

http://forums.ni.com/t5/Multifunction-DAQ/Update-USB-TC01-Firmware/m-p/3168789#M86726

 

Although now that I re-read your message your firmware is too new, my issue was it was too old.  I'm unsure if this tool can downgrade.

0 Kudos
Message 7 of 7
(1,656 Views)