LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Strange error from NI FPGA compile server

Solved!
Go to solution

Getting this error killing my LabVIEW FPGA compilation on the cloud compile server:

 

/opt/apps/NIFPGA/programs/vivado2019_1/bin/loader: line 267: 5614 Killed "$RDI_PROG" "$@"
Parent process (pid 5614) has died. This helper process will now exit

 

There doesn't seem to be anything online regarding this error. Is this a bug in the compile server or is there something I can do on my end to fix it?

 

Thanks

0 Kudos
Message 1 of 8
(946 Views)

Can you try compiling a shipping example?  Locally?


Certified LabVIEW Architect, Certified Professional Instructor
ALE Consultants

Introduction to LabVIEW FPGA for RF, Radar, and Electronic Warfare Applications
0 Kudos
Message 2 of 8
(943 Views)

Hi, yes I've tried... The computer just hangs and freezes -- have to do a manual reboot to get it to restart.

0 Kudos
Message 3 of 8
(940 Views)
Solution
Accepted by topic author itst1357

That sounds like a really fundamental configuration issue.  I'd try a different computer or uninstalling/re-installing everything.  Or somehow to roll back.


Certified LabVIEW Architect, Certified Professional Instructor
ALE Consultants

Introduction to LabVIEW FPGA for RF, Radar, and Electronic Warfare Applications
0 Kudos
Message 4 of 8
(932 Views)

Thanks for the response. I will try that. I also want to try updating Vivado (currently using 2019.1.1_AR73110) but it doesn't seem like that is an option with LabVIEW FPGA...

0 Kudos
Message 5 of 8
(927 Views)

You are not using the NI provided Vivado (Xilinx) compile tools?  The one from Xilinx may work but that could be your problem.

 

See https://www.ni.com/en-us/support/downloads/software-products/download.labview-fpga-compilation-tool....


Certified LabVIEW Architect, Certified Professional Instructor
ALE Consultants

Introduction to LabVIEW FPGA for RF, Radar, and Electronic Warfare Applications
0 Kudos
Message 6 of 8
(923 Views)

I am using the NI-provided compiler -- the version that is wrapped in Labview FPGA 2020 is the 2019 Xilinx compiler. I am hoping that this may be fixed in the next release (FPGA 2021).

0 Kudos
Message 7 of 8
(810 Views)

This seems to be a configuration issue.  Or am I missing something?


Certified LabVIEW Architect, Certified Professional Instructor
ALE Consultants

Introduction to LabVIEW FPGA for RF, Radar, and Electronic Warfare Applications
0 Kudos
Message 8 of 8
(807 Views)