LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Steps in deploying final program

Problem solved!

 

I spoke with NI's technical support engineers and after adding some drivers to my installation everything worked fine. Thanks for your time, guys.

 

Brian

0 Kudos
Message 31 of 36
(407 Views)

Brian,


Can you share the details of what drivers you needed to add?  I think I am running into the same problem you had.

 

Thanks!

0 Kudos
Message 32 of 36
(393 Views)

Hi Doug,

 

What I did was go to http://search.ni.com/nisearch/app/main/p/bot/no/ap/tech/lang/en/pg/1/sn/catnav:du,ssnav:sup/q/compac... and select the first one in the list provided (compactRIO Module Software version 4.0.1). 

 

Running this file on the target computer solved it.

 

Good luck.

Brian

Message 33 of 36
(385 Views)

Thanks Brian - that did the trick!

 

0 Kudos
Message 34 of 36
(378 Views)

Cool.

 

When I spoke to Tech Support it sounds like there was something missing in my project setup that should have included the necessary drivers. I'm still not sure where or how to make this happen automatically but since I am only deploying to a couple of test stations this way of doing it is fine too.

 

Brian

0 Kudos
Message 35 of 36
(376 Views)

Did you ever find out what drivers were missing?  I am currently building a project which also does not have a need for a VI on the RT target.  I have a Host VI on the PC and the FPGA VI that is called by that host.  It works fine in the development environment and also as an .exe on the devolpment computer.  When I build the installer, I include LabVIEW 2011 Runtime engine, NI-RIO 4.0 (and I also downloaded the update to 4.0.1)

 

But I am still seeing the missing "nifpgalv.dll" message when I install on another PC.  My previous version of this project had a Host vi on the PC, a vi on the RT target (cRIO-9012/9112) and the FPGA.vi and everything installed ok.  But even then the cRIO VI had minimal code on it, nothing to do with the FPGA references.  Is it necessary to have ANY vi running on the cRIO for this project to build correctly?  FPGA straight to PC?

0 Kudos
Message 36 of 36
(338 Views)