LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Some fonts are not shown correctly in LabVIEW 2012

I found a bug related with fonts in LabVIEW2012 f3 KR.

- When I select NI7SEG in font selection dialog, right font is not shown in the example box.

- Draw text at point.vi shows same problem for some fonts while other fonts are working.

 

I reported it to Korean NI. As far as I know, this was not reported in previous versions and I couldn't find any related documents in Google. 

 

So, here I would like to know whether it is related with only Korean version. Please let me know if English version is OK. 

 

* OS: Windows 7 32bit KR

 

 

Font Issue.png

 

 

 

0 Kudos
Message 1 of 9
(1,919 Views)

This font ins not installed by default, you need to get it from here.

 

It looks just fine in LabVIEW 2012f3 32bit (english)


LabVIEW Champion Do more with less code and in less time
0 Kudos
Message 2 of 9
(1,908 Views)

Thank altenbach,

 

The font and both of 2010 and 2012 versions are installed in my PC. All of pictures are from my PC. Even "Arial" font is not display correctly.

 

So, now I can conclude only Korean version has a problem displaying fonts.

0 Kudos
Message 3 of 9
(1,901 Views)

Just now, I installed LabVIEW 2012 f3 (32-bit, English) and checked for the issue. But the font(NI7SEG) was not shown properly in VI either.

 

- Both of Korea and English version of LabVIEW 2012 on Win 7 Korea OS shows wrong results. It is same on 64-bit OS.

- LabVIEW 2010 but on same PC shows correct fonts.

 

Is there a limit of number of fonts in LabVIEW? There are more than 100 fonts are shown in the "Selection Font" dialog and I can divide them into 3 groups by sequential order. I find that all fonts in the 3rd group are not applied correctly.

 

(1st group)
Arial Unicode MS...
Bookshelf Symbol 3....

Windings 3


(2nd group)

@Arial Unicode MS...
@Terminal

 

(3rd group)

Arial...

Consolas...

Courier...  

Licida Console... 

NI7SEG...

Verdana

0 Kudos
Message 4 of 9
(1,865 Views)

From what I see the last group of fonts does not work! Have you figured what is the difference between 1st and 3rd group.. where is this defined?

0 Kudos
Message 5 of 9
(841 Views)

I don't know the difference, but a workaround I found is to add a line with fonts I want to use to LabVIEW.ini file:

 

FontCodePageList=Cambria,1252;Calibri,1252;Consolas, 1252;Segoe UI,1252;Segoe UI Light,1252;Small Fonts,1252;Verdana,1252

 

Note that this line will allow small fonts to work like a charm in LabVIEW Icon Editor.

Message 6 of 9
(836 Views)

Fantastic, this works like a charm!

Thanks!

0 Kudos
Message 7 of 9
(831 Views)

Do you know what's meaning of 1252? thanks.

 

FontCodePageList=Cambria,1252;Calibri,1252;Consolas, 1252;Segoe UI,1252;Segoe UI Light,1252;Small Fonts,1252;Verdana,1252

 


 

Message 8 of 9
(746 Views)

Please see this and this.

 

 

Message 9 of 9
(741 Views)