LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Slow exe launch, auto root certificate update

This topic can be found previously in a 2011 forum post, link at bottom of post.

My target PC has no internet connection, the LabVIEW .exe takes 35 seconds to launch.  If the internet is connected, 2-4 seconds to launch.  Windows is trying to look online for a digital certificate, but it times out and the .exe opens anyway without any prompt to let the user know the check has failed.

One solution is a reg edit to prevent Windows making the check, as detailed in the 2011 forum thread.

The customer(s) are not keen on loosening the security settings of Windows to accommodate my application.

Is there another solution that would not involve requesting changes to the operating environment?

 

https://forums.ni.com/t5/LabVIEW/slow-loading-time-of-Labview-executable-application-on-pc/td-p/1689...

 

0 Kudos
Message 1 of 8
(411 Views)

It seems to be their issue not yours.
You can't have a valid locally hosted SSL certificate, if you have not Internet connection then they need to provide access to a copy of the certificate on the intranet available to your PC or suffer the extra 30 sec slow down on Program load if they are not going to relax the IT rules.
Blame their IT dept. when it gets too much of a headache they'll relax, change the need to get the certificate on Load (Never seen it before myself - are you digitally signing you code?, maybe you just don't if you are!)

James

CLD; LabVIEW since 8.0, Currently have LabVIEW 2015 SP1, 2018SP1 & 2020 installed
0 Kudos
Message 2 of 8
(398 Views)

I'm not digitally signing the code, I have very limited knowledge of how digital signatures work.  I'm using fairly standard build options in LabVIEW to create an exe which is copied to the target machine, no installer.  The issue came to light when the code was used on PCs without an internet connection, prior to that I was unaware any checking of certificates was taking place.

0 Kudos
Message 3 of 8
(362 Views)

Ahh that'll be the NI certificate check then. You can't get around it. It's their IT issue or you have to completely re-write in another programming language. I've seen that once before on a defense installation. They opted for launching the S/W at the start of the day with an auto launch script from the program folder on logon to reduce slowdown. I suspect they've got nasty user user timeouts as well for security reasons if you're hitting that sort of issue. Your end user wants speed as they are assessed on timed metrics and IT wants security (IT always wins in the end). 
Don't waste too much time on it. 😉

James

CLD; LabVIEW since 8.0, Currently have LabVIEW 2015 SP1, 2018SP1 & 2020 installed
0 Kudos
Message 4 of 8
(327 Views)

I created a project with one button and one indicator LED.  It takes 34 seconds to open on my target PC when the internet is disconnected.  2 seconds when the internet is available.

On my desktop PC, it opens in 2 seconds regardless of internet connected/disconnected if I connect/remove the LAN cable from the rear of the PC.

 

On the problem target PC, the LAN cable is still connected to allow access to networked drives.  The network administrator has disabled the internet by doing this:

 

right-click windows icon and select "Network Connections"
click on button "Properties" for the local LAN
Under IP Settings, click "edit" button
Change pull-down menu from Manual to Automatic(DHCP)
Click "Save".
Close setting windows.
Start internet browser and confirm connection is gone.

0 Kudos
Message 5 of 8
(280 Views)

It's definitely a very low level check.
Have you tried looking at the INI file parameters and seeing if you can change those to something that clears the error (by building with a different INI file in the EXE).
Wondering if any of the default params are causing you issue - like TCP access and TCP Server settings.
[default build]
server.app.propertiesEnabled=True
server.ole.enabled=True
server.tcp.serviceName="My Computer/VI Server"
server.vi.propertiesEnabled=True
WebServer.TcpAccess="c+*"
WebServer.ViAccess="+*"
DebugServerEnabled=False
DebugServerWaitOnLaunch=False

maybe try:
[default build]
server.app.propertiesEnabled=False
server.ole.enabled=False
server.tcp.serviceName="My Computer/VI Server"    << change??
server.vi.propertiesEnabled=True    << change??
WebServer.TcpAccess="c+*"   << change / turn off??
WebServer.ViAccess="+*"    << change/turn off??
DebugServerEnabled=False
DebugServerWaitOnLaunch=False

James

CLD; LabVIEW since 8.0, Currently have LabVIEW 2015 SP1, 2018SP1 & 2020 installed
0 Kudos
Message 6 of 8
(266 Views)

I have just discovered that LabVIEW.exe, the development environment takes 37 seconds to open on the target PC.

On my desktop PC the same open takes 3 seconds for the initial splash screen to appear.

Whatever is delaying the application.exe is also delaying LabVIEW.exe

0 Kudos
Message 7 of 8
(263 Views)

I know...
As I have previously stated. I've seen this before...
I think you're going down a rabbit hole. I don't think there is a solution.
I don't currently have access to the SR I raised years ago at a previous company when I encountered this, but as previously stated I believe it's a very low level thing (LabVIEW RTE license check or something.) and there is no work around (as a batch file to launch explorer, and kill after 2 secs will be killed as a virus after a month (- it was for me) by the security settings, but you could try it).
Blame IT and give up or you'll lose days chasing ghosts.😉
I'm trying to find the original SR and get the answer I was given then.

James

CLD; LabVIEW since 8.0, Currently have LabVIEW 2015 SP1, 2018SP1 & 2020 installed
0 Kudos
Message 8 of 8
(252 Views)