LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Single pixel (1px) border missing on LabVIEW windows in Windows 10

Solved!
Go to solution
Highlighted

Anybody else running LabVIEW 2017 on Windows 10 see a missing pixel along the left, bottom, and right edges of LabVIEW windows when maximized, both in built executables AND in the development environment? By missing, I mean you can see the background image/color of the Windows Desktop.

TL;DR- If anybody knows how to set the color of this pixel (or the width to zero), you're the big winner Smiley Wink

 

I noticed this in one of my applications that runs maximized, and it turns out all of the EXEs from my team have this feature (as opposed to Outlook, Excel, Chrome, etc). After some time spent digging in the EXE ini file, build spec settings, VI window appearance settings, and VI property nodes, I couldn't find anything obvious.

Then I maximized my main VI in the IDE, same thing. Then I maximized a new blank VI, same thing.

 

Looks fine using Alt-PrintScreen (1px border, mid-grey). Looks fine un-maximized (1px border, mid-grey), see attached with MSPaint fill bucket set to red x2. Doesn't matter if the background is set to a picture or solid color, or if the desktop settings > Colors > Accent Color is picked or set to "Automatically pick... from my background". Duplicated the behavior on a Windows 10 box with no LabVIEW IDE (via a LabVIEW executable). Same behavior on 3 external monitors, 1 external HDMI monitor, or just my laptop monitor in both IDE and EXE. Any help is appreciated.

0 Kudos
Message 1 of 8
(1,051 Views)

Now that you mentioned it...

 

On my Windows 10) it isn't a single color. The 1 pixel is simply not drawn, and everything behind it shows through. It even updates, as windows behind it update...

 

Note that modal panels don't have this border. Although hardly worth the name (it would be terrible), it could be a workaround in some cases.

0 Kudos
Message 2 of 8
(1,005 Views)

What have you done?? I haven't noticed this in the years of using LabVIEW on Win 10, but now I'll never be able to unsee it...  Thanks for nothing Smiley Very Happy

 

It definitely looks like a bug in LabVIEW, since no other applications that I can see have this 1-pixel gap.  I have no idea how to get rid of it without some really weird LabVIEW wizardry which in my head feels like way more work than it's worth.

 

---
David Ladolcetta - Certified LabVIEW Architect
DSP Tools Engineer - Cirrus Logic

Message 3 of 8
(985 Views)

Here's a hack to " fix" it. Actually, just a potential starting point towards a solution.

 

Simple.png

 

Putting the attached VI (Rescale Fullscreen Window.vi) in any diagram will do it automagically.

 

There are a few known issues:

+ It will only work during run time (the VI needs to run).

+ It will resize even if there's no Windows 10 bug.

+ Even on Windows 10, it might not always be 1 pixel (probably a setting somewhere).

+ When the maximized title bar is dragged, normally the window resized back to the old size. It doesn't do that anymore...

+ It's completely untested, undocumented, and unfounded.

Message 4 of 8
(977 Views)

@David_L, I know, right?!? Welcome to team "can't un-see it"

@weibe@CARYA, Satisfying hack for the days when I want to claw my eyes out over this! Maybe I can add in an OS call to check if it's Windows 10, and store off the previous size from the Panel resize for the un-minimize action.

Sounds like a CAR for NI.

0 Kudos
Message 5 of 8
(940 Views)

It's a (cosmetic) bug I never have noticed so far. Part of it may be that I pretty much hate to run maximized applications. Luckily I use a fairly dark background so it won't bother me, even if I now will be unable to not see it Smiley Mad

Rolf Kalbermatter
Averna BV
LabVIEW ArchitectLabVIEW ChampionLabVIEW Instructor
0 Kudos
Message 6 of 8
(924 Views)
Solution
Accepted by topic author Ryan_Griffin
03-29-2018 11:39 AM

Just confirmed it with a colleague who had Windows 10 and LabVIEW 2017 on their computer. A dark background does make it tougher to see, but it's definitely there. Nice catch! Filed a CAR under number 690324.

 

Have a great weekend, y'all! 

Claire M.
Applications Engineering
National Instruments
Certified LabVIEW Developer
Message 7 of 8
(897 Views)

@ybalam wrote:

Just confirmed it with a colleague who had Windows 10 and LabVIEW 2017 on their computer. A dark background does make it tougher to see, but it's definitely there. Nice catch! Filed a CAR under number 690324.

 

Have a great weekend, y'all! 


BTW. LabVIEW 2013 has the same behavior.

0 Kudos
Message 8 of 8
(857 Views)