LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Sillicon Labs UART USB Communication with NI MAX and LabVIEW

Solved!
Go to solution

Hello,
I'm writing with a similar title than another post (which was not solved) as I get the same problem:
https://forums.ni.com/t5/LabVIEW/Sillicon-Labs-UART-USB-Communication-with-LabVIEW/td-p/3293021


I try to connect with the UART-USB interface of an FPGA Development Kit which uses the chip Silicon Labs CP2104.
I'm working with LabVIEW 2017 SP1 on Windows 10.

In the Device manager, the interface is recognized properly as "Silicon Labs CP210X USB to UART Bridge (COM3)".
Now in MAX there is nothing appearing in "Devices and Interfaces", so I'm not even speaking about LabVIEW (in which no VISA resource is seen).


As in the post mentioned before I've tried to refresh NI MAX, reinstall drivers, restart computer, change COM port.. without success. And I'm now running out of ideas.
Then I ask for your help.


Thanks in advance!
Stephane

0 Kudos
Message 1 of 3
(525 Views)
Solution
Accepted by topic author Sgabi
04-23-2018 02:10 AM

Hello again,

after a nice weekend to change mind, I was suggested to check how well installed were the NI-VISA drivers.

And indeed as it was a new installation of LabVIEW from my company, the drivers were not automatically installed.

After doing it manually, it just works.

 

Just to mention, in my previous post, when I spoke about "reinstall drivers", I was speaking about the Silicon Labs ones only...

A nice week is starting Smiley Happy

0 Kudos
Message 2 of 3
(486 Views)

Good to know it was a simple solution, reach out again if you need more help.

 

Cheers!

0 Kudos
Message 3 of 3
(473 Views)