Showing results for 
Search instead for 
Did you mean: 

Shared Variables deployment failed

Go to solution



I am having trouble deploying a shared variable.

when my exe runs i get the following error.


Calculating dependencies...
Checking items for conflicts. This operation could take a while...
Preparing items for download. This operation could take a while...
Deploying My Computer
Deploying Shared Variables.lvlib\\\Shared Variables deployment failed (error: -1967362042, OS and Network Services: (Hex 0x8ABC7006) Unable to start service.).
Deployment completed with errors
Do you wish to run the application anyway or abort the execution?


I have tried to google the error code but my search has been unsucsessful as of yet. Has anyone else come accross this particular error? It would be helpful if it said what service in particular couldn't be started!


Any help would be greatly appreciated!


Thnaks for looking,


0 Kudos
Message 1 of 10

Go to services and make sure the NI Variable Engine is running.

Glad to answer questions. Thanks for any KUDOS or marked solutions 😉
Message 2 of 10
Accepted by Goomba79

Welcome to the World of Partly Helpful LabVIEW Error Messages (though they generally have Microsoft beat by a mile here).


What version of LabVIEW are you running?  Is this the only version that has been installed on your PC?  [The reason to ask this is I, and others, have experienced installing, say, LabVIEW 2015 on a system which already has LabVIEW 2014, something that is "legal" and should work, but during the Installation, various NI Services are stopped and not restarted.  One Service, necessary for the functioning of Shared Variables, is the NI Variable Service].


In fact, while composing this Post, I went to my Services (because I wanted to be sure to specify the correct Service), only to find that the Service is (again) missing, and the Shared Variable Engine is (again) not available.  Indeed, I get exactly the same error message.


So here's how I'm going to (try to) fix it.  I'll go to Control Panel, Programs and Features, National Instruments, and will Repair LabVIEW 2015 (32-bit).  I expect this process to take about 30 minutes (if I'm lucky) -- I'll post back here my results ...


Bob Schor

Message 3 of 10

Well, that did, indeed, fix it -- the NI Variable Engine is running again as a Service (to see Services, go to the Start Menu, type "Services" in the Search box, choose the thing with the Gear icon).  It took 34 minutes to repair LabVIEW 2015, then I had to repair 6 or 7 other things, so there was some disk-swapping ...


Bob Schor


P.S. -- it is possible that, having fixed the rest of my machines with this problem, I failed to fix this one, but I thought I did this first ...

Message 4 of 10
Thanks for the advice!

I shall check the service first thing tomorrow when I'm back in the office.
I am running LabVIEW 2013, it works fine on my machine, but when I installed it on another pc I got the error.

If that fixes it i'll have to make a little routine that checks the service on startup!

I shall let you both know how I get on tomorrow!

0 Kudos
Message 5 of 10

If it isn't completely dead, like Bob said, I have seen the service not start in time for deployment on slower machines. I then could abort the program, wait a bit, and it would start up fine after that.

On one of my older development computers the service started on some reboots, but not on others. It wasn't a production system, and it didn't happen often, so I just started it when needed.

Glad to answer questions. Thanks for any KUDOS or marked solutions 😉
Message 6 of 10

If the Repair works, then you shouldn't need to "check it on Start Up" -- it should continue to work until you do another LabVIEW install (or install a patch from NI Update).  You'll know when you do those, so you can easily check "manually", if you are worried.



Message 7 of 10



I Check this morning and the NI shared Variable service was not running. Restarted the service and everything seems to running ok!

Thank you all very much for the help, it's greatly appreciaated!!


0 Kudos
Message 8 of 10
I had the same problem. Thanks for the information. I looked at the services and indeed this one was not in the list any more. The strange part is that it happened when the system was operational before. Anybody any idea what could cause the process to stop?
Problems will keep comming... Lets hope the answers do that to.
Never give up without a fight...
0 Kudos
Message 9 of 10


I have a similar error when trying to deploy shared variables to cdaq 9132.

I've tried to repair the labview 2015 installation and the variables engine seems to run fine.

What can be the reason for the attached error?




0 Kudos
Message 10 of 10