LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Shared Variable programatic access error -1967362038

I am trying to read/write about 300 tags from a AB ControlLogix 5561 processor from Labview 2011 on windows XP SP2 through RSLinx Classic OEM OPC Server.

 

At first, I tried to do everything through front panel data binding through Datasocket, but I've seen that it becomes slow/unreliable when the bound control count reaches beyond 100 tags or so. Wrong values are read/written, some controls just won't bind intially or lose thier binding...it's really odd. So, I've put all of my faith in Labview's DSC module to solve all of my problems.  

 

I installed it on a development system, played around with the programmatic access VI's using the NI's test OPC server and everything worked great. It really looked like the answer to all of my problems but upon installing it on the target system I can't get it to work the same way! 

 

I've created a library of simply 3 bound variables to the PLC through an IO server pointing at the local instance of RSLinx. I am able to browse the PLC tag structure, so at least the link through RSLinx is working to some extent.

 

Fairly often, when running the seach variable container vi on that library, I get error -1967362038 with explaination  "IAK_SHARED". When this error occurs, the same error shows up in the distributed system manager and the shared variables can no longer be read. I can't seem to pin down a pattern but happens every few minutes or roughly ever 3rd or 4th time I start the vi. When it happens, the only way I've found to get things working again is to undeploy and redeploy the library, while watching it in the distributed system manager, then continually loop the search variable container VI for a few seconds and eventually, the variable comes back to life.

 

Does this sound like an issue with RSLinx? One of the previous posts related to this error mentioned that it may be due to some corrupt files in MAX?

 

Other network published shared variables (non-OPC) seem to be OK so I think this is a problem related to the DSC module.  

 

I rebooted twice immediately after the DSC installation.

I have uninstalled SQL Server 2005 and the DSC module and reinstalled both. Twice.

 

What could be causing this error?

Would it be worth while to port over to the NI OPC Server?

 

0 Kudos
Message 1 of 2
(1,069 Views)

Hi pjrose,

 

First, I notice that this post is pretty similar to a service request that one of my colleagues has been working on. Are you working with another NI Applications Engineer on this issue?

 

That said, the issue could very well be related to the DSC module. I doubt that the error is a MAX corruption error, at least at present. One thing that would be worth checking would be the connections on your network. Additionally, what are the types of variables that you are accessing, and how specifically are you coding the access to them? If you could post an example of how you're accessing them, that would be helpful.

 

Best,

Dan N

Applications Engineer

National Instruments 

0 Kudos
Message 2 of 2
(1,045 Views)