LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Setra 370 not working with labview 2017

i am having problem making  setra 370 pressure absolute work with labview 2017. it work perfectly on older  labview 8.2.  i think this are the errors  1. instrument driver error, which say instrument assist i/o may not be correctly installed. our IT guy say its installed correctly.  2. its not correctly seeing setra in the NI Max  3. copying the VI's from older version of LabView to the new created some issue.

please if anyone have any solution on how the setra 370 work with labview 2017. pluse when i copy the VI from the older versions is there a specific backgound program or file  i need to copy  and transfer with the VI's?

 

0 Kudos
Message 1 of 4
(1,334 Views)

Hi,

 

1. For converting code from previous versions of LabVIEW there is a helpful document on our website, here. From 8.2, it should be relatively straightforward where you'll just need to do a single "Mass Compile" to convert it to LabVIEW 2017.

 

2. Generally, when looking for a third-party driver, I check our third party driver's page and I also check the company's page. However, after looking at these, I don't see a driver.

 

3. I did find that the device uses RS-232 (Serial) on the datasheet. Thus, you could use our NI-VISA commands to interface with it, but you'll need to know how to communicate with the device via serial, which should be in the manual.

 

4. How does this work with LabVIEW 8.2? Are you using VISA commands? Do you have a driver that I am unable to find on my end?

 

Regards,

 

Timothy D.
Applications Engineering
National Instruments
Message 2 of 4
(1,287 Views)

Hi 

1. now i am able  to convert from labview 8.2 to 2017 successfully .

2. i have been looking for the driver on labview 8.2 and i can't find it either 

3. the main problem i am having is that  our new laptop(Dell Precision 7510) has no connection pin for the RS-232.  i was trying to use converters from RS-232 to USB but i am  unsuccessful in communicating with the setra 370. i have set the baud rate on the setra to match with my computer. but still not working.

4. yes we are using a visa command on labview 8.2. but like you i can't find the driver. the only explanation i got is the old laptop  accept the RS-232 cable,and our new laptop don't. may be that is why it ask for a driver. This problems occurs only when using Setra 

0 Kudos
Message 3 of 4
(1,254 Views)

Hey, thanks for the response!

 

5. With the RS-232 to USB cable, that introduces a translation that may need to be accounted for, via another driver. Hopefully it would just work as if it were the RS-232 directly connected. Do you know the manufacturer/model number of the cable?

 

6. So, does it currently work with LabVIEW 8.2, using VISA commands? If so, it sounds like we are on the right path to getting it working in LabVIEW 2017. You should just need to implement the same commands with 2017.

 

7. If you do not have it working in LabVIEW 8.2, we don't have a way to know how a 3rd party device communicates via serial. Thus, you would need to reach out to the manufacturer to find out how to communicate with the device.

 

I hope we are able to get you up and running soon!

Timothy D.
Applications Engineering
National Instruments
0 Kudos
Message 4 of 4
(1,248 Views)