LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Session could not be configured

Solved!
Go to solution
Highlighted

Hello everyone,

 

I would like to use a Manta G283C camera (from Allied Vision Technology - AVT) with Labview, but when I want to test the camera using MAX, then I get the error 0xBFFF800B saying "the session of your device could not be configured" (see attached file).

I have other AVT cameras that are working fine (like the Manta G125C that you can see on the sent screenshot). The problem seems to be specific to this camera.

 

Here is what I've done so far (in chronological order):

- I've installed the AVT Vimba software and I can use the camera with it.

- I checked if I can use the camera with a third party software, and I can. (software: Common Vision Block, from Stemmer Imaging)

- I've reinstalled the IMAQdx drivers, hopping it would help Labview to understand that there is a new camera to configure. Nothing changed.

- I looked on NI website and ended up finding this page about Troubleshooting GigE Vision Camera. Looking at the third point, it says that sometime the XML file get corrupted. I used the CameraValidator program to generate a new XML file, and I ran into another problem (that might be related to the fact that I can't use the camera). During the XML file generation, the program encounters an "unhandled exception" (see file attached). So I guess no correct XML file can be generated.

- On the Troubleshooting page I just mentionned, following the link List of GigE Vision cameras on NI Camera Advisor, I saw that the Manta G283C is not listed. Does it mean that it is not supported ?

 

I am running out of ideas... It seems to be a problem related to the Labview environment, since I can use the camera with the manufacturer software Vimba, as well as with a third party software (Common Vision Block, from Stemmer Imaging).

 

Does anyone have a suggestion?

If the fact that the camera is not listed in the List of GigE Vision cameras on NI Camera Advisor means that it is not supported, is there away to find a solution? Like using file from a different camera and making Labview think it is the correct file for the Manta G283C, even if I loose the ability to set one or two camera attributes?...

 

Thanks in advance.

Best regards.

Luc

0 Kudos
Message 1 of 6
(1,248 Views)

Good morning everyone.

I refresh the message, hoping someone would have a suggestion to make.

Thanks in advance.

Regards.

Luc

0 Kudos
Message 2 of 6
(1,176 Views)

If your camera is not found then National Instruments has not tested the camera and does not officially support it, but the following options are still possible:

  • Create a custom camera file using the NI Camera File Generator.
  • Check the Discussion Forums to see if another user has previously created a custom camera file.

Edit: Ref:http://digital.ni.com/public.nsf/allkb/4331B4AA3AE95233862574C200539A2F

-So,I believe there should be a way.

-Try deleting the xml, iid and icd files in Documents and Settings/All Users/Shared Documents/National Instruments/NI-IMAQdx/Data, then remove camera and connect again to generate the files.

-And try regenrating files.

-Update the IMAQdx driver version(What version you have currently?).

Thanks
uday
0 Kudos
Message 3 of 6
(1,161 Views)

Thank you for your answer.

I agree with you. There should be a way. If standards are defined, it is (normally) to provide compatibility between devices and softwares without necessarily testing *all* the available devices on the market.

 

- I searched on the forum but didn't find any information that could help me on that matter.

- I deleted the files that you suggested and powered ON the camera again. New xml and iid files (before I open MAX), but no icd. That did not solve the problem. Is the icd file supposed to be created before opening MAX or only when I click on the camera to display the parameters (inside MAX) ?

- I downloaded and installed the file generator from NI website, but it didn't solve my problem. If I try to create a new camera, the only manufacturer that are available are others than Allied Vision. I can't find my camera, which seems logical since the Camera File Generator is supposedly for serial cameras (like Camera Link for instance), and not GigE.

- I am using IMAQdx 16.0.0. I'll look for newer version, but I suppose the one I have should be recent enough to make the camera work. The Manta G283C is not a brand new camera on the market.

 

I contacted NI technical support. We'll see what they say.

0 Kudos
Message 4 of 6
(1,144 Views)
Solution
Accepted by topic author LucG

So in regards to support, as long as the camera follows the GenICam standard it should work. Of course this doesn't mean that everything is going to work the first time but from my experience we tend to work well with many camera vendors to figure out where the problem lies so one of us can fix it for future releases.

 

I remember we had some problems recently cameras with an update to the standard that resulted in very similar behavior which I believe was resolved in the 16.0.1 release so I would definitely recommend updating the drivers. A few cameras were effected but Manta G came up quite frequently. The KB below describes what the problem was and how to check your camera's xml file to see if that was the problem.

 

http://digital.ni.com/public.nsf/allkb/596D16E8C1290AA586257FD3000CAD12?OpenDocument

 

Matt J
National Instruments | CLA
Message 5 of 6
(1,134 Views)

Hi.

Updating the driver worked.

I would not have expected a minor upgrade to solve the problem, but hey! It's by doing mistake that we learn. Now I know. Smiley Wink

Thanks a lot.

0 Kudos
Message 6 of 6
(1,126 Views)