LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Serial communication problem - Modbus ASCII

Solved!
Go to solution

Hey,

I try to communicate with a temperature control via VISA. I have problems to understand the received message. The answer to my input string (:070310000001) was :0783096D. I thought 83 stands for the "Function Code" and 09 for the "Exception Code", but I can not find what exactly is the meaning of this.

The process value should normally be something about 21°C (room temperature).

 

Thanks for help!

0 Kudos
Message 1 of 28
(958 Views)

There are modbus libraries available to use so that you don't have to code your own.

 

0 Kudos
Message 2 of 28
(933 Views)

Also this one, which is newer.

0 Kudos
Message 3 of 28
(931 Views)

Thanks for your fast answer!

I want to use the VISA ressources in Labview. Is it possible to combine them?

0 Kudos
Message 4 of 28
(927 Views)

Yes.  Those Modbus libraries use the VISA resources.

0 Kudos
Message 5 of 28
(925 Views)

I tried the example: MB_Master Simple Serial. I made all approaches, but there still comes a error message: 1073807339.

Shouldn´t it work with this example?

 

I am a total beginner with Labview and Modbus, so I am happy about every help!

 

0 Kudos
Message 6 of 28
(919 Views)

@StefanieWernet wrote:

I tried the example: MB_Master Simple Serial. I made all approaches, but there still comes a error message: 1073807339.


-1073807339 is a timeout error.  Perhaps your instrument is not setup to talk over the serial bus?


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
0 Kudos
Message 7 of 28
(916 Views)

The instrument communicated via a different program with me, so in my opinion there should be no problem.

I have the correct VISA Ressource and Slave ID. Where else can be the problem?

0 Kudos
Message 8 of 28
(912 Views)

Don't know.  Post some code so we can see what you did.

 

Perhaps your serial settings are wrong.  Maybe your slave address is wrong even though you think it is correct.

0 Kudos
Message 9 of 28
(907 Views)

Going back to my starting problem with the modbus code:

I think it is a Modbus exception code with 09. In all the lists of exceptions codes (e.g.: http://www.simplymodbus.ca/exceptions.htm), there is always 01 till 08 and then 0A (10), but no 09.

Can someone explain this to me?

 

0 Kudos
Message 10 of 28
(905 Views)