LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Saving source distribution for previous version

Solved!
Go to solution

Hi,

 

I'm trying to use Run Labview VI tool in VBAI. I'm using LV2013 SP1 and VBAI 2013. The Run Labview VI step gives me an error saying "this step supports LV2012 or earlier". When I save it for LV12, this time an error comes up saying " The VI was not compiled for the specified remote target or it was not saved with LV12". After I read the forums and help documents, I see this problem can be solved with saving the VI for distribution (LLB).

 

But when I open the project, it is becoming LV2013 and LLB is building as LV2013. So I'm returning the first step saying "this step supports LV2012.."

 

How can I build a source distribution as LV12 while using LV13? I couldn't find a solution.

0 Kudos
Message 1 of 8
(3,725 Views)
The problem is likely that saving in a previous version, saves the VI but doesn't actually recompile it in that version -- a pretty reasonable approach.

Mike...

Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 2 of 8
(3,695 Views)

I couldn't understand your suggestion about this problem. Is it possible to compile the VI in a previous version? If it is, how can I do that?

0 Kudos
Message 3 of 8
(3,679 Views)
My suspicion is that while LV 2013 can save the source in a form that is compatible with LV 2012. It can't compile the code for that version in a later version. To create an executable 2012 VI, you need LV 2012 -- which is only a download away.

Mike...

Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 4 of 8
(3,664 Views)
Solution
Accepted by topic author sevincom

You can either download an 2012 version (ask your local sales engineer because it's an older version), or

 "save your VI as" for 2012 and post the zip of exported files to the conversion board. Someone may answer and wrap your files in a 2012 VI+llb ^^

- http://forums.ni.com/t5/Version-Conversion/bd-p/VersionConversion

 

--Eric 

Eric M. - Senior Software Engineer
Certified LabVIEW Architect - Certified LabVIEW Embedded Systems Developer - Certified LabWindows™/CVI Developer
Neosoft Technologies inc.

0 Kudos
Message 5 of 8
(3,642 Views)

Mike, Eric

 

Thank you both. I installed an older version. I think this situation needs to be improved. Also a similar problem is with VBAI which doesn't have an option for saving as previous version.

0 Kudos
Message 6 of 8
(3,629 Views)

I believe VBAI 2010 is when we added support for VBAI to recompile the VI for you if it is saved in the same or earlier version and not compiled for the version of LV that VBAI expects. We do not currently support saving VBAI inspections to an earlier version, but you can always add this feature to our Vision Idea Exchange (I'm sure it will get lots of votes:> )

http://forums.ni.com/t5/Vision-Idea-Exchange/idb-p/visionideas

 

Hope this helps,

Brad

0 Kudos
Message 7 of 8
(3,611 Views)

Brad,

I think, compiling option of VBAI doesn't work very good (at least it never worked for me Smiley Happy )

On the other hand, I will add saving for previous version to Idea Exchange. I hope, it takes interest of other users.

 

Edit: Added that in Vision Idea Exchange: http://forums.ni.com/t5/Vision-Idea-Exchange/Saving-for-previous-version-in-VBAI/idi-p/3077224

0 Kudos
Message 8 of 8
(3,594 Views)