LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Saved data in text file doesn´t show decimal places

Solved!
Go to solution

Hey there!

I feel like i am posting quite a lot of questions but i am a complete amateur in LabVIEW and not a programmer so this is the place to go for me..

Anyways, i am sending data from my arduino board to LabVIEW and the values of my sensors are shown correctly on my front panel, BUT in my text file the decimal places are missing.

 

Screenshot (29).png

 

As you can see here, the values are complete, but in the following image you see that the decimal places in my text file are missing

 

Screenshot (30).png

 

I personally think, that the problem is with the way my values are written. In arduino comes first a point " . " and then the decimal places. For example "12.34". But LabVIEW recognizes as seperation sign only a comma " , ". So for the decimal places to show in my text file, the values have to look like this "12,34". But yeah that is not the case and also not possible. 

Does my theory make sense and more importantly, how can i fix this? Because i can not change the way arduino displays the data.

 

Thanks for any help!😊

0 Kudos
Message 1 of 4
(146 Views)
Solution
Accepted by topic author Jugo

It is coming from a system setting in your OS.  You apparently live in a region where the comma is used as the decimal separator instead of a period.  Use "%.;%f" for your format at the Array To Spreadsheet String.  The "%.;" part forces the node to use the period for the decimal separator.

 

EDIT: You should do the same thing for your Spreadsheet String To Array.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
Message 2 of 4
(142 Views)
You can specify the radix separator in your format strings. LabVIEW defaults to the OS localized setting but %: and %; can be used to override that default. Check the format specifiers section in the help file

"Should be" isn't "Is" -Jay
Message 3 of 4
(137 Views)

Hey man 😊

 

yeah i changed it and it works perfectly!!!😁

 

Screenshot (31).png

Screenshot (32).png

 

Thank you so much i really appreciate it!

0 Kudos
Message 4 of 4
(85 Views)