LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

SVE tags in System Manager show "Process Failure" after power cycling PLC

I have a cRIO-9074 connected to a computer to monitor data from our machine. I'm using Windows 10 64-bit and running LabView 2009. The problem started after Windows updated from 7 to Windows 10. I recently installed a trial of LabView 2011 to see if there's any tools that can troubleshoot this. The problem is every time the machine (and the PLC) gets powered down, we lose the ability to monitor tag data from the OPC variables set up. I think I've narrowed the problem down to the OPC client (Shared Variable Engine) not receiving data properly from the PLC. Does the IP address reset after a power cycle or something?

 

I tested the OPC connection with OPC Test Client and Matrikon OPC Explorer. The connection is there but when I add a tag from the OPC there is no value being read. I've tried stopping and starting National Instruments Shared Variable Engine in Windows Services, undeploying and redeploying all variables, and of course turning the PLC on and off. A picture is attached showing process failure for all tags under OPC_Variables in System Manager 2009.

0 Kudos
Message 1 of 4
(192 Views)

I think I solved it. I read in a few online forums that a Windows 10 update from 2018 broke a lot of OPC connections so I updated to the latest version as of today, version 20H2 and the PLC is being read and datalogged properly again. After updating Windows 10 I shut off the computer and the NI PLC system, waited 3 minutes, turned the PLC system back on, waited another minute, then turned the computer back on. Immediately I was able to go into System Manager and see that values are being read.

 

https://opcfoundation.org/forum/classic-opc-da-ae-hda-xml-da-etc/problems-after-windows-update/

0 Kudos
Message 2 of 4
(126 Views)

Windows update did not fix the problem. When the PLC was powered down for machine maintenance, the OPC connection broke again. I powered down both the computer and the PLC, and powering them up in order as I've done before. I restarted NI Configuration Manager services, NI Shared Variable Engine services, and undeploying, and deploying all variables. Every attempt fails to connect the tags to read from the PLC properly. I updated to latest cumulative Windows 10 update today.

0 Kudos
Message 3 of 4
(48 Views)

Short update. I downloaded Process Explorer from the Microsoft website (https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer) to look closer at the NI tag server process tagsrv.exe and the associated service NI Tagger Service. There are certain threads that hold up the process but by looking at the TCP/IP connections for that process I see a connection appear and disappear. The host server is trying to connect to the remote server (localhost, SVE OPC server) and shows up with a SYN_SENT status, then disappears after a few seconds. This happens every few seconds. Does this mean the host computer is sending a synchronization request to the NI Shared Variable Engine server and the server isn't taking it? or is this being sent to the PLC and the PLC isn't taking it? I've tried creating an inbound and outbound firewall rule that allows all TCP connections in associated with the NI Tagger Service but that does not fix the problem.

0 Kudos
Message 4 of 4
(15 Views)